Odd issue: OPCOM can't find groups

  1. 7 years ago
    Edited 7 years ago by HeroesandvillainsOS

    This is a real head-spinner.

    So I updated a mission I released over on BIS forums the other day. It's been playing fine for me and other users over the last few months and I even ran it on my own server a few nights back. A couple days ago, I decided it would be a good idea to add dynamic weather and tinker a bit with the call to prayer from Spyder Addons because why not (famous last words :) )?

    Now suddenly, when I start Arma and open the mission in the editor, OPCOM fails to find groups. BUT, and here's the odd and unique part, when you exit back to the editor and press play again, the mission works just fine. All groups are found. Strange!

    So troubleshooting this, I opened and closed all of the modules which didn't work. I then reversed the changes I made from my update and that didn't work. I then deleted and replaced every ALiVE module and that didn't work either. I then deleted and replaced every ALiVE module, removed everything from my mission file except the mission.sqm, deleted the Binarized Addons section of my mission.sqm and opened and closed everything else (markers, etc) and that didn't work either. Even using OPF_F instead of a modded faction doesn't work either. Neither OPCOM can find groups until I esc and play the mission again.

    I don't expect anyone to be able to solve this for me, but I'd feel wrong not at least starting this thread incase someday someone sees something similar. I'll also update this thread if I make any progress. What makes me pretty confident there isn't a deeper issue going on here is that other missions I've done (and one I released) still work just fine and have the same exact dependencies and features so I'm really not sure what the deal with the one mission is.

    I do have a rpt file though note I use a lot of mods (and the rpt itself is honestly pretty eye opening too because there are quite a few errors I wasn't aware of. Yikes):


    Bad mission: https://forums.bistudio.com/topic/190913-alive-spcoop-1-8-prophet/

    And it's working identical twin: https://forums.bistudio.com/topic/192272-alive-spcoop-1-8-inshallah/

    And it's cousin on FATA which uses the same mods aside from the map:

    I'm totally stumped but I'll keep on keeping on. :) If anyone has any suggestions I'm all ears though! Honestly, at this stage I'd just rebuild it from scratch (and if I were reading this thread, I'd tell that person to rebuild it from scratch too!) but I hate to have to remake my bases again (ugh) until I've exhausted every other option. I already tried just copy/pasting the mission to a fresh map but for some reason that makes objects float (literally) 10,000 meters above the ground.

  2. Did you try with the "public" build instead of the one on GitHub? It might be an issue with the pre-release builds.

  3. Edited 7 years ago by HeroesandvillainsOS

    Yeah I did. Thanks for the suggestion. I means a lot! The issue detailed here is with the public build unfortunately. I did try the dev build just to see but that makes the mission infinite-load until I crash with unable to init DXGI. :(

    You'd think maybe I just needed to verify my game files or whatnot but the problem was reported to me by another user after I updated it a couple days ago. He also tried changing the faction to vanilla and no dice.

    It's just weird because I was playing this thing on my server I think the night before last?

  4. Edited 7 years ago by marceldev89

    I see that you're hosting the mission on dropbox. Can you download a working version of the mission with the help of dropbox's "previous version" functionality and post a link to that one as well?

  5. Edited 7 years ago by marceldev89

    Just browsed the mission.sqm and noticed that the commander modules use SomeFaction instead of ["SomeFaction"]. Not sure if it's important but worth a shot. :)

  6. Edited 7 years ago by HeroesandvillainsOS

    Interesting idea. I wasn't aware of the feature. Hopefully it lets me go back a few because I intentionally posted a borked version last night, after having posted a version which I thought I had everything fixed, thinking maybe someone would see an obvious issue I may had just been overlooking.

    This is a good lesson in the art of keeping functioning backups. Very stupid of me to not keep one in hindsight.

    Thanks for the headsup. I'll check.

  7. Edited 7 years ago by HeroesandvillainsOS

    @marceldev89 Just browsed the mission.sqm and noticed that the commander modules use SomeFaction instead of ["SomeFaction"]. Not sure if it's important but worth a shot. :)

    Oh cool. I'll add the quotes and see. Seriously, all these ideas are wonderful and I appreciate it a lot.

  8. Edited 7 years ago by SpyderBlack723

    Just browsed the mission.sqm and noticed that the commander modules use SomeFaction instead of ["SomeFaction"]. Not sure if it's important but worth a shot. :)

    That's a perfectly valid input. The module parses the incoming string and produces it's own array.

    "BLU_F,BLU_G_F" becomes ["BLU_F","BLU_G_F"] behind the scenes

    see mil_opcom "convert" operation

  9. Edited 7 years ago by HeroesandvillainsOS

    Marceldev, thanks for the suggestion about looking for backups on Dropbox. I had no idea the feature existed and it did indeed have several older files for me. The good news is, I have a file from August 18th which works just fine. The bad news is, the second I change anything in the mission - such as adding a module or deleting a module - the problem comes back. Kind of.

    This time, the issue is effecting BLUFOR only (3CB) instead of both OPCOMs. What's happening now is, half of the time when the mission starts, it just totally ignores the mil/civ placement modules entirely. And the other half of the time, it spawns all units perfectly. I went back through my normal troubleshooting steps (deleting and replacing modules, etc) but none of that seems to help at all.

    I have a rpt from a successful initialization in the first example, and a rpt from a non-successful initialization in the second example:


    This leaves me at sort of a standstill. Although I'm happy a salvageable version of my mission exists, based on what I'm seeing it would also seem to indicate I could never edit it again because doing so would break it. At this stage it might make more sense for me to just bite the bullet and rebuilt it from (*gulp*) scratch. Though if anything jumps out in the rpt's I'd still be eager to continue trying to save it. And again, I really appreciate all the help so far.

  10. Send me the least broken version. As in, if it's working, add something to it to break it then send to me. Preferably no additional mods or at least bare minimum because I don't have any installed.

  11. Edited 7 years ago by HeroesandvillainsOS

    I'm not sure if you can access this page without being logged in my account or not, but if so, the link has an option to download a version of the mission from August 18th. That seems to work.


    Though this version is kind of a mess. I won't bore you, but just know I'm aware I have several instances of redundant or unnecessary overlapping markers, too many custom obj modules for efficiency (this is a build from a time before I started experimenting with using the "tiny" objective filtering) and a list of several other things. I point this out because it seemed to me these thing in themselves could be the source of the problem, but I did go through this build and cleaned a lot of it up and it doesn't fix the issue with units not spawning.

    Anyway, the fastest way to break this build I think would be simply to just add a dynamic weather module. Save the mission and exit the game and open the mission again. And even deleting it after doesn't seem to fix the problem once it starts.

    If that doesn't work, another (and probably more reliable) way would be to delete all of the OPF_MTI_F cust obj modules - aside from the ones hovering over yellow objects - and changing the OPF_MTI_F civ obj module to spawn units ignoring only tiny objectives. And maybe go ahead and increase the 3CB mil obj spawns from 100 to 200 for good measure. And again, save it and exit the game and start the mission again. Sometimes you need to exit/launch the game a couple times for the problem to appear.

    And I promise no offense taken if you don't feel like downloading the requirements needed. I know internet access is a bit tricky for you ATM so I totally get it if this is too much hassle. I myself am even tempted at this stage just to change the factions entirely to bring the mod requirements down. Maybe just deleting everything and copy/pasting just the bases and compounds to a fresh map and just starting over and going with RHS and Project OPFOR instead. That in itself would drop 6 (6!) mods completely which may not be a bad thing in the long run.

  12. Nope, can't access that link. Click on share to the right of the item and then click create link in the dialog that pops up.

  13. https://www.dropbox.com/s/bb4oz55nu6qmhh7/Prophet.Reshmaan.pbo?dl=0

  14. @SpyderBlack723 I just decided to copy/paste all of my bases and compositions to a new map and just completely rebuild the mission from there. I exited and entered the mission 3 times and it seems to work just fine (fingers crossed).

    I'll just put the solved tag on this even though I do believe on some level I have exposed an undiscovered conflict, which couldn't be solved even by deleting all of the ALiVE modules and assets. I'll just hope it never happens again.

    Thanks for your help and thanks to @marceldev89 too.

  15. If anybody can ever repro with significantly less required mods or most preferred vanilla, I can take a closer look.

  16. Haha yeah I don't blame you for not trying to duplicate it if you didn't already have most of the mods already. If I ever see it again in a less mod intensive environment (gosh I hope not), I'll bump the thread.

  17. Edited 7 years ago by HeroesandvillainsOS

    Ok. I know I thought I had solved this but I hadn't. Now I think I have officially found and fixed the problem.

    So after making my first ever ORBAT faction, I went though 3 of my missions and replaced the original faction with the new one (as noted above, they are all identical missions to one another aside from the map) and AGAIN, my Reshmaan mission and Reshmaan mission alone broke. BLUFOR (3CB) would not spawn. Even after rebuilding the mission (which was how I fixed it the first time).

    So I took a breather and tried to rationalize things. I thought to myself, "What's different about THIS mission?" Well, the map. So I thought, "What's different about the map?" Well, the size. Reshmaan is an enormous beast of a map while the other two (FATA and Takistan) are relatively small.

    It took me about a second from that moment to realize the problem could be stemming from the CQB module because of how large and object dense it is. So I deleted the CQB module that was synced to the BLUFOR (3CB) mil obj module (lowering the amount of units within the module didn't help. I had to delete it) and the problem now, finally, seems to be fixed.

    This leads me to wonder now, what gives? I have the same setup for all three missions. All of them have 2 CQB modules. One is synced to the OPFOR Assymetric OPCOM and the other synced to the BLUFOR mil obj module. But with this one mission, doing this method fundamentally breaks it.

    So I have to wonder, how the heck are you supposed to set up CQB to work for each side, when one side is an Assymetric commander and the other an invasion/occupation commander? Here's an unanswered question below in a quote tag I asked in this thread:


    If anyone gets a chance, I'd still love an "official" recommendation for how to have BLUFOR and OPFOR utilize CQB when OPFOR is an Assymetric commander.

    Even though it *seems* ok having OPF_F,BLU_F in one CQB module synced to the Assymetric (OPF_F) Commander, it still *feels* wrong having BLU_F written in the module when it's synced to the opposing side's OPCOM.

    And looking at some of AuTigerGrad's missions, he uses two (or more) CQB modules. One synced to the Assymetric commander, and another free standing one with the other side written in it. Both set to dominant.

    I'm not saying the way I described it or the way he's doing it aren't both correct ways (I realize it's more of an ambient troops spawner than anything), it's just I don't think it's super obvious how to use it in an Assymetric situation, when syncing to an OPCOM is in play.

    What I want to do is have an Assymetric mission where just the dominant faction utilizes CQB. Is the "correct" way to use one module (synced to the Assymetric OPCOM with both sides written in) or two modules (one synced to OPCOM and one free standing one for the other side)?

  18. Question for @highhead

  19. 6 years ago
    Edited 6 years ago by HeroesandvillainsOS

    Ahhh! :( F me it's back lol.

    Well not in the same mission, but in a new one. Strange.

    So just to recap, the issue goes like this. Open Steam and start the game. Open the editor. Open the mission. Press play. No virtualized units spawn. BUT...

    Hit esc and quit to the editor. Press play. Units spawn properly and will continue to everytime you start the mission from this point forward.

    This can be repeated over and over again. The first time the game is launched and the mission is started, virtualized units don't appear. But every time after that they will. Until you close the game again.

    Prior to this, I actually "fixed" it in my other mission by deleting and ultimately replacing the CQB module. However, this time, I'm not as fortunate. I guess I'd have to assume some module is corrupted, but what on earth would make a mission work fine, but only after failing on the first attempt?

    It makes me wonder if some critical ALiVE or game data gets cached on the client somehow. My missions always load more smoothly on the second attempt.

    Anyway, it's frustrating this keeps happening. I'm just bumping this to remove the "solved" tag in the event someone else ever experiences it.

  20. 3 years ago

    It's not necromancy if the thread isn't dead. Hello 2020, I just had this issue. The mission was running fine, three factions. Somewhere in the day of build>test>iterate I suddenly out of the blue got "the message for not having an ALiVE supported faction.

    And it was fine, it was calling out the one I was a player in. Restarted the mission, logged in as the other faction and the error message repeated, this time blaming the faction I was playing as.

    Saved the mission backup, deleted one entire faction... problem went away.

    Does that Make sense to _anyone_?!

  21. Newer ›

or Sign Up to reply!