Locally hosted persistence saving (SOLVED)

  1. 4 years ago

    I've been trying to set up a local persistence save for a multiplayer mission I have created for a friend and me to play on and it just doesn't work when I save and exit.

    • All modules are set up including Data Module, Player Options etc.
    • All modules that require persistence to be set up have been set to yes.
    • Data Module has been set to Local

    When I host the mission in server browser>host mission and play for a while then try and save & exit it gives me 3 lines which are..
    "ALiVE Pausing state of ALiVE_ALiVE_sys_profile instance set to true!"
    "ALiVE Pausing state of ALiVE_ALiVE_mil_command instance set to true!"
    "ALiVE Pausing state of ALiVE_ALiVE_fnc_analysis instance set to true!"

    After that, it doesn't exit and when I "server exit" and load back in nothing has been saved.

    Please help I have been struggling with this for 2 weeks now.


  2. Hmmm. Can you post the mission here? I can take a look. Please just be sure it only requires the smallest amount of mods.

  3. Edited 4 years ago by TSWhiskey

    Thanks so much! Here is the link
    link text

    Tried to clean as much as I could please let me know if I need to remove some more.

    Thanks for the quick response!

  4. Edited 4 years ago by HeroesandvillainsOS

    @TSWhiskey Please post the required mods here in text form in your post so I can read what it needs (I’m on mobile right now and want to see the requirements), and put the direct PBO or mission file link here (Dropbox ideally, but Google drive is fine).

  5. Ok I'm at home on my PC now and that link has a 404 error. Just link me the pbo or entire mission folder zipped up. Just list the mods the mission uses in the post with the link.

  6. Ok, will do!

    Sorry, I'm from South Africa so the time zones are going to be a bit different. Will jump on it right away.

  7. So I have uploaded the .pbo to dropbox as well as a snip of the required mods. I have deleted most of the mission except for the alive modules and the spawn point. Ran a test and it still doesn't save.

    Heres the dropbox link.
    link text

    PS: Noticed that I did not include an AI commander for BLUFOR only using alive for OPFOR, do i require for both sides? Could that be the problem?

    Thanks again

  8. I won’t be able to look at it for a bit. May be worth placing a BLU Commander module down with at least one custom objective module set to spawn a couple units just to see. Not sure myself but I’ve asked in our Slack as I’ve never tried to persist a mission without a player Commander.

  9. Dev consensus seems to be you do not need a player sided Commander module for persistence to work. So apparently that is not the problem. I’ll take a look when I have some time.

  10. Edited 4 years ago by HeroesandvillainsOS

    Ok I unpacked the mission and took a look in the editor. A few things stood out, so try this:

    You synced the IND_C_F Civilian Objective Placement module to the Military Objective Placement module. This is my best guess on the problem because this is wrong. Objective Placement modules are most typically synced to the Military AI Commander module, or less common, not synced to anything at all. These are the only allowed use-cases. Do not sync the Objective Placement modules to each other. I'm assuming you meant to sync this to your Commander module, so do that, and test again.

    Please don't use special characters or spaces for mission names. Although % should be supported, just stop doing that and use underscores. So, OP_Whiskey_Test.Tanoa is better. You had a % (might be supported but stop) and a space (definitely not supported) in there.

    If the above fails, remove ACEX. If that fails, remove ACE. If that fails, let me know and I'll investigate further but at that point we'll need a rpt file from when you attempted to save.

    Oh, one last thing. I'm assuming you don't want mission time of day to persist? You have that set to no. Just letting you know. All other modules, aside from what I mentioned, look fine though.

  11. Thank you for the feedback.

    So I've fixed a few things:

    1. I've synced the IND_C_F Civilian Objective Placement module to the Military Objective Placement module.
    2. Deleted all mods except Alive and CBA.
    3. Removed all special characters and spaces from the name.
    4. Changed mission time of day to persist.
    5. Added a BLUFOR Military AI commander as well as a MIL Objective

    Unfortunately, it still gives me the exact same result.

    link text

    Here is the dropbox link to the cleaned mission, including a snip of the mods used and a screenshot of what happens when I try to save.

    Completely Baffled!

  12. Sorry if I’m being confusing.

    I've synced the IND_C_F Civilian Objective Placement module to the Military Objective Placement module.

    That’s how you had it when I checked your mission yesterday and this is wrong. Civilian and Military Objective Placement modules should never be synced to each other. You should only be syncing Objective Placement modules to the Military AI Commander modules.

  13. Sorry I did fix it XD! Synced the civ objective to the AI commander! My mistake

  14. Im being the one who's confusing! So everything is fixed the way you asked and its still not working.

  15. Edited 4 years ago by HeroesandvillainsOS

    Hey I’m not home now. So the mission above only requires ALiVE and CBA? Perfect. Open the mission and try to save it in a local hosted MP session by hitting esc, and hitting “server save and exit.” Fully Exit Arma. Open your users folder on your PC, then appdata, then local, then Arma 3, then find the time stamped rpt file and post that here along with the mission file that requires only ALiVE and CBA.

  16. Yes only requires ALiVE and CBA.

    Done, I've added the rpt file to the Dropbox folder under this link.

    link text

  17. Edited 4 years ago by HeroesandvillainsOS

    One of our Devs looked at your rpt file. He says you’re running -nologs

    This makes the rpt file useless. Please run and submit again without the -nolog command. Also can you explain what makes you think the mission isn’t persisting? Best way to check is to enable Virtual AI debug and take a screenshot of profile positions and comparing upon continuing the mission. Also note other things as well, the in-game clock time when saving and continuing, and player position (if you have that set to persist).

    Are you not being greeted with a message in the top right corner of your mission state being loaded when you launch the mission after a save?

  18. I'll quickly generate a new rpt file with -nologs switched off sorry!

    I'm sure, I've checked the time as well as destroyed buildings vehicles did missions cleared areas etc. and every time it just resets. Also no message in the top right corner.

  19. Edited 4 years ago by HeroesandvillainsOS

    Does this mission persist for you? Maybe it’s an Arma game directory or profile directory issue...basically something PC related and not mission related.


    PBO is linked there. Requires Spyder Addons. If local saving is working on your PC, this mission will save and continue.

  20. Edited 4 years ago by TSWhiskey

    Ok so I fixed the RPT file here's the new link

  21. Newer ›

or Sign Up to reply!