Server crash after 2 hours of operation

  1. 3 years ago

    Exits with:
    17:39:58 ErrorMessage: Too many virtual memory blocks requested
    17:39:58 Application terminated intentionally
    ErrorMessage: Too many virtual memory blocks requested

    Mod list
    USAF Mod - Utility
    USAF Mod - Main
    Advanced Combat Radio Environment 2
    Advanced Combat Environment Extras 3.5.0
    ShackTac User Interface
    Chernarus Redux
    Project OPFOR
    CUP Terrains - Maps 1.13.0
    UP Terrains - Core 1.13.0
    Advanced Combat Environment 3.13.0
    RHS: Armed Forces of the Russian Federation
    RHS: United States Forces
    Enhanced Movement
    USAF Mod - Fighters
    Community Base Addons v3.13.0
    7th Cavalry Gaming Community Addon
    Arma 3: ALiVE
    Arma 3 Contact (Platform)
    Arma 3 Tanks
    Arma 3 Tac-Ops
    Arma 3 Laws of War
    Arma 3 Malden
    Arma 3 Jets
    Arma 3 Apex
    Arma 3 Marksmen
    Arma 3 Helicopters
    Arma 3 Karts
    Arma 3 Zeus
    Arma 3

    Any help would be greatly appreciated. Thanks in advance.

  2. What does your startup command look like?

  3. Edited 3 years ago by johnny0964

    We've been getting the same problem consistently. It either crashes when the game goes on for 2 hours or more or when a player joins in after about 30 minutes or more. Every RPT ends with the same error you described. We use quite a few mods, but we haven't been able to reproduce this on any other game mode. I will post my RPT when I get the chance

    Here's my startup commands

    -port=2582 -MaxMem=16384 "-servermod=" "-mod=@CBA_A3;@ace;@ACRE2;@RHSUSAF;@RHSAFRF;@RHSGREF;@RHSSAF;@ALiVE;@aliveserver;@3CBFactions;@ACEAdvCPR;@ACEDiwakoRagdoll;@ACESplint;@Achilles;@Align;@BackpackOnChest;@BlastStandalone;@BreachCharge;@CTabDupe;@CUPTerrainsCore;@CUPTerrainsMaps;@Immerse;@MarauderGear;@SOUG;@Spyder;@Suppress;@tfvfac;@VcomAI;@hmd;@hmdrhs;@ProjectBJC;@ACEX;@USP;@offroad;@KAT;@Boxloader1;@Boxloader2;@torabora;@hazarkot;" -profiles=ARMAHOSTS -config=ARMAHOSTS\server\server.cfg -cfg=ARMAHOSTS\server\basic.cfg "-name=armahosts" -Server
  4. Nothing jumps out, but
    @BlastStandalone; is this blastcore,

    @aliveserver; should be loaded as a server mod,

    And a few mods are not compatible with the new release of ace, @ACEAdvCPR, @ACESplint; and if @kat is kept medical its also not compatible

    And personally I have had lag and memory leak issues when running the vcomai,

  5. That is blastcore, yes.

    Aliveserver was ran as a server mod today. Crash happened once again.

    ACEAdvCPR and the other medical mods are 100% compatible because we do not use the newest version of ACE because of its butchering of the medical system and we will not use it until it is fixed.

    We don't know if this issue is even ALiVE related anymore. Earlier today we ran a different mission (a modified Evannex scenario) and the error happened again; player joined the game and we received the same crash at the end. It could be ACRE, VCOM, or any other mod at this point.

  6. Can you post the logs?

  7. I'll post two for comparisons sake. I will have to link them to a google drive since they're too big for pastebin.

    Here is the RPT for the ALiVE mission

    Here it is for the Evannex mission

    We're thinking it could be ACRE2 and are testing out TFAR Beta later tonight and will try to force our server to reproduce the issue.

  8. Edited 3 years ago by YonV

    Most of the errors seem to be acre, but the crash is memory related and i have not seen a memory issue from acre before.

    So the last four ideas I have,

    Do you have the alive pathfinding enabled for the ai?

    -MaxMem=16384 check with your server host to make sure you have access to that much memory

    Try a different memory a locator , something like " -malloc=tbb4malloc_bi_x64 -hugepages "in your startup

    And this is the one that's sucks, it's one of your mods, so group your mods in to must have, want to have, and nice to have, and start with just the must's

  9. We never used alive pathfinding.

    We do have that much memory; we pay extra for it

    I'll try out the memory allocater soon

    We're checking our mods now and hopefully we'll find the issue

  10. We ran our test. We could not reproduce the error with Task Force Radio instead of ACRE2 after many attempts and playing for quite a few hours. We had players leave and try to rejoin, which usually causes the crash to happen, and no joy. Very odd.

    I can't imagine ACRE2 is fully to blame because so many groups use it and don't report this problem. I haven't found any bug reports about this that mention ACRE2 other than this thread.

  11. if the crash happens when a player joins, you might want to look at that player logs also.

  12. We reneabled ACRE2 and once again we crashed with the same error. OP the only way we fixed the issue was switch from ACRE2 to Tfar unfortunately

  13. Edited 3 years ago by YonV

    acre2 crashing a server, this is the first time i have heard of that issue,

    If you use 3den Enhanced you can pre program the radios for tfar, so no one has to deal with it in missions.

  14. Yeah, it's very odd. It's great to know that ALiVE isn't doing it so our gameplay will still be essentially the same.

    I'm wondering if ACRE2 is not playing nice with another mod we have loaded. I haven't been able to find *any* reports about this particular issue regarding ACRE2 anywhere. You'd think if this was a widespread issue people would be complaining about it on the forums and the steam workshop.

  15. Hey, we believe fixed our issue. Our custom faction mod was spitting out tons of issue errors every single second. The moment it was removed ACRE2 has been working flawlessly. I'm not sure why this would be the case; we made it using the ALiVE ORBAT functionality.

    Weird to say the least. We will confirm this when we play tonight. Thanks for helping out and looking into this for me the past few days. OP may want to try identifying if any of their mods does the same thing. You can see the constant errors and what I'm talking about in the RPTs I added.

  16. Hey, we ran into the same problem. Any update?


or Sign Up to reply!