M

MacHK

Member

Last active 2 months ago

  1. 2 months ago
    Wed Sep 12 01:10:00 2018

    Fantastic question! I have no idea!! Haha.

    I will go check and turn it off and report back if I see anything different.

    Thank you

    **EDIT**

    I do not and did not have Auto-init enabled.

  2. Tue Sep 11 20:21:33 2018

    Hello,

    I've been having an issue where the server loads slowly, or not at all, if a player is slotted in and loads with the initial mission load. If no player connects and the mission loads, there are zero problems and the mission loads VERY fast.

    Does anyone else have this issue?

    I'm sure you'll ask for my server report, I'll have to get it sometime, but I am just curious if anyone has some initial thoughts on this.

    This is with ACE / RHS - maybe someone else has some experience with this and can provide some direction.

  3. last year
    Fri Jan 6 20:26:22 2017
    M MacHK posted in ALiVE 1.2.7 Released.

    Please.... explain step by step how to set up Real Weather? The module says check the wiki.... there is nothing on the wiki.

    Do we put USA/MIAMI in the field? Is it UnitedStatesofAmerica? America?

    Please, thanks:)

  4. 3 years ago
    Sat Nov 14 21:55:25 2015
    M MacHK posted in SOLVED Problem with ALiVE_fnc.

    I am having the same problem.

  5. Sat Apr 18 16:34:16 2015

    BEAUTIFUL start up log without any errors :) Thank you very much for the new update and would just like to say that all of my problems with startup have been resolved. I will attempt a server save and relaunch sometime and confirm that works, but, I assume that it will :) I will post my launch log if you would like it. Thank you again.

  6. Tue Apr 14 23:12:24 2015
    M MacHK posted in Insurgency Not Happening.

    Are you running a non-standard faction? If so, make sure you check out the wiki's supported faction page. Some factions that are not on the list work perfectly fine, but I am not sure what factions work with insurgency. Further, the insurgency takes time - maybe more time than you gave it - however, something should have happened by then I feel. Make sure you double check your civilian modules as they are important. Make sure you have the modules properly synced as well with a defined TOAR.

  7. Tue Apr 14 21:39:08 2015

    My apologies for multiple response, I am just trying to give as much information as I can about what is going on as I have no idea what any of this means.

    After my previous post... the errors did eventually stop (after 40,000 lines) and now THIS happened... which also did eventually stop.

    17:37:00   Error position: <_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error Undefined variable in expression: _position
    17:37:00 File x\alive\addons\sys_profile\fnc_createProfilesFromGroupConfig.sqf, line 211
    17:37:00 Error in expression < 1;
    [_profileEntity, "addUnit", [_class,_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error position: <_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error Undefined variable in expression: _position
    17:37:00 File x\alive\addons\sys_profile\fnc_createProfilesFromGroupConfig.sqf, line 211
    17:37:00 Error in expression < 1;
    [_profileEntity, "addUnit", [_class,_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error position: <_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error Undefined variable in expression: _position
    17:37:00 File x\alive\addons\sys_profile\fnc_createProfilesFromGroupConfig.sqf, line 211
    17:37:00 Error in expression < 1;
    [_profileEntity, "addUnit", [_class,_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error position: <_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error Undefined variable in expression: _position
    17:37:00 File x\alive\addons\sys_profile\fnc_createProfilesFromGroupConfig.sqf, line 211
    17:37:00 Error in expression < 1;
    [_profileEntity, "addUnit", [_class,_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error position: <_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error Undefined variable in expression: _position
    17:37:00 File x\alive\addons\sys_profile\fnc_createProfilesFromGroupConfig.sqf, line 211
    17:37:00 Error in expression < 1;
    [_profileEntity, "addUnit", [_class,_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error position: <_position,0,_rank]] call ALIVE_fnc_profi>
    17:37:00   Error Undefined variable in expression: _position
    17:37:00 File x\alive\addons\sys_profile\fnc_createProfilesFromGroupConfig.sqf, line 211
    17:37:00 Error in expression <ileEntity;
    [_profileEntity, "position", _position] call ALIVE_fnc_profileEntity;>
    17:37:00   Error position: <_position] call ALIVE_fnc_profileEntity;>
    17:37:00   Error Undefined variable in expression: _position
    17:37:00 File x\alive\addons\sys_profile\fnc_createProfilesFromGroupConfig.sqf, line 127
    17:37:00 Error in expression <;
    _dir  = _this select 2;
    
    
    if(typename _pos == "OBJECT") then {_pos = getpos _p>
    17:37:00   Error position: <_pos == "OBJECT") then {_pos = getpos _p>
    17:37:00   Error Undefined variable in expression: _pos
    17:37:00 File A3\functions_f\geometry\fn_relPos.sqf, line 21
    17:37:00 Error in expression <roup = _groups select _i;
    
    _position = [_position, (random(200)), random(360)] c>
    17:37:00   Error position: <_position, (random(200)), random(360)] c>
    17:37:00   Error Undefined variable in expression: _position
    17:37:00 File x\alive\addons\x_lib\functions\composition\fnc_spawnRandomPopulatedComposition.sqf, line 134
    17:37:00 Error in expression <;
    _dir  = _this select 2;
    
    
    if(typename _pos == "OBJECT") then {_pos = getpos _p>
    17:37:00   Error position: <_pos == "OBJECT") then {_pos = getpos _p>
    17:37:00   Error Undefined variable in expression: _pos
    17:37:00 File A3\functions_f\geometry\fn_relPos.sqf, line 21
    17:37:00 Error in expression <roup = _groups select _i;
    
    _position = [_position, (random(200)), random(360)] c>
    17:37:00   Error position: <_position, (random(200)), random(360)] c>
    17:37:00   Error Undefined variable in expression: _position
    17:37:00 File x\alive\addons\x_lib\functions\composition\fnc_spawnRandomPopulatedComposition.sqf, line 134

    IMPORTANT NOTE: THE SERVER DID START - but with this and the last post occuring (FRESH pbo/loadname)

  8. Tue Apr 14 21:37:02 2015

    Now I am getting a separate error after trying the same mission with different LoadNames and PBO Names - so the problem is not singular to only after saving.

    17:33:08 "Administrator/BIS_fnc_log: [module] ALIVE_fnc_C2ISTARInit (1047.99 ms)"
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
    
    _dis1 = _position distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error position: <distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error Type Not a Number, expected Number
    17:33:09 File A3\functions_f\misc\fn_inTrigger.sqf, line 80
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
    
    _dis1 = _position distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error position: <distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error Type Not a Number, expected Number
    17:33:09 File A3\functions_f\misc\fn_inTrigger.sqf, line 80
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
    
    _dis1 = _position distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error position: <distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error Type Not a Number, expected Number
    17:33:09 File A3\functions_f\misc\fn_inTrigger.sqf, line 80
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
    
    _dis1 = _position distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error position: <distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error Type Not a Number, expected Number
    17:33:09 File A3\functions_f\misc\fn_inTrigger.sqf, line 80
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
    
    _dis1 = _position distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error position: <distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error Type Not a Number, expected Number
    17:33:09 File A3\functions_f\misc\fn_inTrigger.sqf, line 80
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
    
    _dis1 = _position distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error position: <distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error Type Not a Number, expected Number
    17:33:09 File A3\functions_f\misc\fn_inTrigger.sqf, line 80
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
    
    _dis1 = _position distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error position: <distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error Type Not a Number, expected Number
    17:33:09 File A3\functions_f\misc\fn_inTrigger.sqf, line 80
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
    
    _dis1 = _position distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error position: <distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error Type Not a Number, expected Number
    17:33:09 File A3\functions_f\misc\fn_inTrigger.sqf, line 80
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
    
    _dis1 = _position distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error position: <distance _posF1;
    _dis2 = _position dista>
    17:33:09   Error Type Not a Number, expected Number
    17:33:09 File A3\functions_f\misc\fn_inTrigger.sqf, line 80
    17:33:09 Error in expression <2;
    _total = 2 * _tx;
  9. Tue Apr 14 01:19:25 2015

    Here is the issue I am having.. I have tried both with the latest CBA version and also with the previous version just to check compatibility and the exact same thing happens at the exact same time.... Here is some of the code surrounding the error. Note: The error continues forever after this posting the exact same thing over and over again.

    21:14:52  ------------------ Inspection Complete -------------------- 
    21:14:52 ALiVE [m_10|43] Module ALiVE_SYS_spotrep INIT COMPLETE TIME:  1.368
    21:14:52 "Administrator/BIS_fnc_log: [module] ALIVE_fnc_emptyInit (906.998 ms)"
    21:14:52 ALiVE MAP BOUNDS: 13000
    21:14:53 [AGM] Server: agm_core is Version 0.9502.
    21:14:53 "Administrator/BIS_fnc_log: [BIS_fnc_preload] ----- Scripts initialized at 84610 ms -----"
    21:14:54 "Administrator/BIS_fnc_log: [module] ALIVE_fnc_emptyInit (1370.01 ms)"
    21:14:54 "Administrator/BIS_fnc_log: [module] ALIVE_fnc_emptyInit (1806.99 ms)"
    21:14:55 Error in expression < 0;
    _char = _charArray select _pos;
    if (_char == 58) then {
    
    
    _key = toString _t>
    21:14:55   Error position: <_char == 58) then {
    
    
    _key = toString _t>
    21:14:55   Error Undefined variable in expression: _char
    21:14:55 File x\alive\addons\x_lib\functions\data\fnc_parseJSON.sqf, line 91
    21:14:55 Error in expression <"_char"];
    _char = 0;
    _char = _charArray select _pos;
    if (_char == 58) then {
    
    
    _>
    21:14:55   Error position: <select _pos;
    if (_char == 58) then {
    
    
    _>
    21:14:55   Error Zero divisor
    21:14:55 File x\alive\addons\x_lib\functions\data\fnc_parseJSON.sqf, line 90
    21:14:55 Error in expression <"_char"];
    _char = 0;
    _char = _charArray select _pos;
    if (_char == 58) then {
    
    
    _>
    21:14:55   Error position: <select _pos;
    if (_char == 58) then {
    
    
    _>

    Server will not start but will not 'crash.'

  10. Mon Apr 6 02:05:50 2015
    M MacHK started the conversation AI Response and Awareness Issue.

    Hello,

    I was wondering if anyone else ever has seen this happen or know of a way to integrate other AI - such as UPSMON or GAIA from MCC - into ALiVE because it seems as though you can be engaging one squad, they are engaging back, and other squads within only a hundred to 300 meters do not engage you and don't care - they don't response.

    Is there a way to fix this? Is there any thoughts / plans on how to fix this? I view this as one of the major issues because it breaks immersion and gameplay when you know that other AI can hear whats going on, you're killing their friends, and they just stand there.

    Any advice / thoughts would be helpful. Thank you.

    Mac

View more