M

M.Shifty

Member

Last active 2 months ago

  1. 2 months ago
    Sat Mar 3 00:10:54 2018
    M M.Shifty posted in Server save and exit not working.

    Just to confirm, you want me to try loading it in the editor and hosting it from there?

  2. Sat Mar 3 00:09:55 2018
    M M.Shifty posted in Server save and exit not working.

    WIlco, I'll let you guys know once I get back to my place this week.

  3. Tue Feb 27 00:37:51 2018
    M M.Shifty posted in Server save and exit not working.

    remade the mission with very limited mods so we could try playing it on the server. For some reason save and exit still isnt working.

    Mods were
    cba, ALIVE,ace,acex,spyder_addons and tfar to make sure everything we needed was working. Not sure whats going on but its back to the original issue (running on a dedicated server)

    I've included the rpt here and a mission pbo incase you need it. Figured ace and tfar wouldnt break anything since on the sample missions it seems to do ok? Any advice on what I'm doing wrong would be great, thanks again guys!

    rpt:
    https://www.dropbox.com/s/r5rov8utjhtpo3e/arma3server_x64_2018-02-26_19-28-09.rpt.txt?dl=0

    mission:
    https://www.dropbox.com/s/hnyefpyypsmwgyd/Landfall_Vanilla.Malden.pbo?dl=0

  4. Sun Feb 25 23:59:24 2018
    M M.Shifty posted in Server save and exit not working.

    Awesome thanks man! I've been trouble shooting this server save and exit thing, it seems to be related to rhs_usarmy_d

    When I tried changing the factions by placing new modules it broke the server save and exit. However when I used those same modules with rhs_usmc_d the same issue of logistics and opcom presented itself. Strange, might be a bug?

  5. Sun Feb 25 19:47:56 2018
    M M.Shifty posted in Server save and exit not working.

    Thanks guys for all the help, glad its finally working somewhat its been puzzling me for ages. :D

  6. Sun Feb 25 19:43:07 2018
    M M.Shifty posted in Server save and exit not working.

    @HeroesandvillainsOS as in when I am in game the logistics option doesn't work. When I click operations it says theres no OPCOM? Not sure whats going on here but the units are still the rhs usmc d like you had them setup.

  7. Sun Feb 25 17:24:45 2018
    M M.Shifty posted in Server save and exit not working.

    Yeah for some reason it's specifically the Malden mission that I made and the Tanoa version you linked me to. I found that when the nato faction was rhs_usarmy_d (not sure if thats the exact name) but either way US army from RHS, the server save and exit (persistence) does not work.

    I tried to modify the by the sword to isolate the problem and thats where I ended up hitting a brick wall. Also @HeroesandvillainsOS when I go into your mission the logistics module is greyed out for me? Is that intended? I was looking for a fix for it. Only way I ended up getting it working was changing the faction and playable units to the RHS US army faction but in doing so seemed to break the persistence. I'll keep you updated if I find anything else, currently in the process of upgrading our server so it might take a little bit.

  8. 3 months ago
    Sat Feb 24 21:05:20 2018
    M M.Shifty posted in Server save and exit not working.

    Update:
    @HeroesandvillainsOS I found your By the sword mission on Clafghan for RHS. Confirmed its working with persistence and all. I'll look into the other missions and see what could potentially be going. I have been using your method of just hitting server save and exit, it works perfectly. Do you think the autosave feature would work? If so how would I go about implementing that.

    Thanks again for the support guys.

  9. Mon Feb 19 23:38:09 2018
    M M.Shifty posted in Server save and exit not working.

    ontop of that, how do I run those commands? I tried throwing it in the debug console but it didnt seem to do anything.

    I'm also not sure how to reset the persistence using those commands on the armahosts server either

  10. Mon Feb 19 23:29:29 2018
    M M.Shifty posted in Server save and exit not working.

    @HeroesandvillainsOS yep so my method is to hit player exit first so it saves the player. Then I go back in and hit server save and exit

    @marceldev I attempted to run it on another dedicated server (hosted on another pc in my house). The location of placed vehicles and time of day save properly, but the player position and loadout does not. I went through the mission that Heroes made and the player options looked all correct. The RPT is below but yeah the RPT indicates everything is saving find except player profiles but even that I'm not sure.

    It seems like everything is working but when we go back and test it the player persistence didn't work at all.

    Test Environment RPT
    https://www.dropbox.com/s/hwm7902t3mg7i20/arma3server_x64_2018-02-19_18-12-51.rpt?dl=0

View more