ORBAT Trouble

  1. last year

    I am trying to work on creating my own factions using the ORBAT. Currently I am just trying to make the RHS VDV faction fully ALiVE compatible. However, I am having some trouble, after I make my faction in the ORBAT and copy the faction to the clipboard, I paste into autogen.hpp. Next I open up the Addon Builder from Arma 3 Tools to pack the PBO. However, when I select the test folder in the source and set destination, I get a build failed result. Here is the full error:

    Build failed. Result code = 1
    CfgConvert task failed.
    File C:\xxx\xxx\xxx\test\autogen.hpp line 7793:/
    CfgVehicles/O_rhsfactionvdvcopy1_GAZ_233114_01/Turrets.CargoTurret_01: Undefined base
    class 'CargoTurret_01'
    Config: some input after EndOfFile.
    Error reading config file 'C:\Users\xxx\xxx\@testmod\addons\test\config.cpp
    Class CBA_Extended_EventHandlers_base destroyed with lock count 5
    Class destroyed with lock count 1

    If I unclick the "Binarize" option in the Addon Builder, it builds a folder test.pbo, but I can't add it as a mod, I get an error that there are no PBO files in the folder. Any suggestions?

  2. There seems to be a specific circumstance(s) that cause the ORBAT Creator to miss a few base classes during the forward declaration phase.

  3. How would I go about fixing this?

  4. There will be several classes missing forward declarations, you just need to scan tbe existing g forward declarations and how they are structured, then recreate those for the missing base classes.

  5. I do that how?

  6. Can you describe how you made this faction?

    Did you copy an existing faction?
    Import an existing faction's units and work from there?
    Create a brand new faction and create new units?

  7. I copied the existing VDV faction, then I was using the technique demonstrated in your youTube video to see if I could make it fully ALiVE compatible. I export and paste to the autogen.hpp, and am using the addon builder included in the Arma 3 tools on Steam as the PBO packer.

  8. Super simple solution. I just needed to export the CfgPatches too and paste that into the CfgPatches included in the @testMod.

  9. Oh. Nevermind. Just got lucky trying a different faction.

  10. So this seems to be fairly specific to RHS and only factions which have the UAZ or GAZ. I've done other factions, including those from RHS GREF and RHS USAF. Haven't done every one though, just FYI for peeps

  11. I've reproduced it once a few weeks ago, but having a hell of time trying make it show itself now..

  12. Still can do it. Take RHS VDV faction, move all groups into their respective appropriate ALIVE compatible facitons, still get same error.

    Tried deleting the config.cpp file, but then although it says the PBO packs appropriately, nothing seems to be there when loaded.

  13. The config.cpp file is the entry point for arma to read the addon

  14. So I have figured out a workaround. It's definitely a problem with copying factions. If you find what vehicle is giving the error, delete it in the ORBAT and then re-add it manually, it works.

  15. Thanks for the info, will give your repro steps a run tomorrow.

  16. So I was able to make some factions with just deleting the certain vehicles that were causing the problems, and individually, the factions work in the editor and Alive. However, if I load two or more factions, only one appears in the editor. Is this normal? Is it something to do with CfgPatches?

  17. Edited last year by SpyderBlack723

    You have to use the CfgPatches export option with every faction.

  18. Ok, so I did that. What I mean is, I make one mod with a new faction in it (export full faction into autogen.hpp and export CfgPatches into that file), then I build the PBO. I do the same with another faction, same method.

    Each of these will load fine on their own into Arma. However if I load both, only the last loaded shows up. Can I paste multiple factions into a single autogen.hpp and CfgPatches? For example copy paste faction A, then paste faction B below it?

  19. Edited last year by Scar3tactics

    Just wanted to add that I'm having the same issue packing and loading pbos when copying a faction. I'm trying to create a copy of the default CSAT with different group compositions. I copy the faction, change the groups, then export both the faction and copy it in to autogen.hpp. I do the same with cfgpatches. When I try to pack the pbo with the BI tools packer I get a "Error in config.cpp" and it fails. I can pack it with a 3rd party packer or by unchecking the binarize box. But then when I try to load the addon in Arma I get a similar error citing the CargoTurret class of the taru helicopters. Very reproducible by trying to make a copy of CSAT faction. I should add I'm not changing any of the units or using any addon units. Just a straight copy of the vanilla faction. (Speaking of changing units, I'm not able to edit load outs of units in a copied faction, only if I open a default faction in the 'Unit Editor' and import from config am I able to edit their loadouts...)

  20. 3 months ago

    Was there ever a solution to be found for this issue? I have the exact same issue when transferring RHS units into my own custom faction. When I try to pack the mod using Arma 3 Tools, I get an error as follows.

    Build failed. Result code= 1
    CfgCovert task failed.
    Filed C:\Users\*me*\Desktop\arma\@rhsusf\addons\test\autogen.hpp, line 3156: / CfgVehicles/rhsusf_m1220_usarmy_d.EventHandlers: Undefined base class 'EventHandlers' Config : some input after EndOfFile.
    Error reading config file 'C:\Users\*me*\Desktop\Arma\@rhsusf\addons\test\config.cpp'
    Class CBA_Extended_EventHandlers_base destroyed with lock count 72.
    Class destroyed with lock count 1.

    I have looked through my autogen.hpp and all the vehicles i tranferred appear to be the same so I am not sure what is causing this bug.

    --------------------
           Binarize -      found: 'D:\Program Files (x86)\Steam\steamapps\common\Arma 3 Tools\Binarize\binarize.exe'.
         CfgConvert -      found: 'D:\Program Files (x86)\Steam\steamapps\common\Arma 3 Tools\CfgConvert\CfgConvert.exe'.
         DsSignFile -      found: 'D:\Program Files (x86)\Steam\steamapps\common\Arma 3 Tools\DSSignFile\DSSignFile.exe'.
           FileBank -      found: 'D:\Program Files (x86)\Steam\steamapps\common\Arma 3 Tools\FileBank\FileBank.exe'.
    --------------------
    Builder starting...
    Clearing temp folder. [temp=]=C:\Users\*me*\AppData\Local\Temp\test
    Done.
    
    Syncing folders... [source]=C:\Users\*me*\Desktop\Arma\@rhsusf\addons\test, [sync]=C:\Users\*me*\AppData\Local\Temp\test
    Done.
    
    Converting configs ...
     - Converting cfg "C:\Users\*me*\Desktop\Arma\@rhsusf\addons\test\config.cpp"
    CfgConvert returned error. Canceling... [result]=1
    Process ended with non-zero code. Exit code: 1
    !> File C:\Users\*me*\Desktop\Arma\@rhsusf\addons\test\autogen.hpp, line 3156: /CfgVehicles/rhsusf_M1220_usarmy_d.EventHandlers: Undefined base class 'EventHandlers'
    !> Config : some input after EndOfFile.
    !> Error reading config file 'C:\Users\*me*\Desktop\Arma\@rhsusf\addons\test\config.cpp'
    !> Class CBA_Extended_EventHandlers_base destroyed with lock count 72
    !> Class  destroyed with lock count 1
    !> 
    Build failed
  21. Newer ›
 

or Sign Up to reply!