Error while joining group in operations

  1. 3 weeks ago

    Hi,

    I am running into an issue with joining in operations on C2ISTAR. Every time I try to join a group I get teleported there but don't actually join the group. I also get an error which displays the code below. Am I doing something wrong or is there anything that needs to be added to the mission to prevent the error from happening?

    '...itUntil {_profile select 2 select 1};
    
    |#|sleep 2;
    
    private _group = _profile sele...'
    Error Generic error in expression
    private _group = ...'
    Error Generic error in expression
    File \X\alive\addons\sup_command\fnc_commandHandler.sqf
    [ALiVE_fnc_commandHandler], line 2298

    Definitely a great mod worth spending a lot of time on. Hope to keep building upon my mission and this would make a huge difference. Also great work on the new military air component commander module!!

    Thanks!

  2. Last I checked and talked with Spyder about it, this is a known bug and I don't think there's a lot they can do about it. In missions with lots of data you're going to see this more.

  3. Do you know if there is any other way or mod that can accomplish the same thing?

    I am basically trying to hop around the battlefield into more instant action scenarios. Don't know if there is another efficient way to do it that and I am just missing it.

  4. Edited 3 weeks ago by HeroesandvillainsOS

    It might be worth seeing if the ALiVE guys can fix this. TBH I used to enjoy it too (though note I haven't tried it in awhile since it started having issues). Can you open a ticket?

    https://github.com/ALiVEOS/ALiVE.OS/issues

    I'm not aware of any mods that'll allow you to do this.

  5. Posted. Thanks for the responsesHeroesandvillianOS

    https://github.com/ALiVEOS/ALiVE.OS/issues/379

  6. I have kept doing some digging and found something similar. Check out the page below. It requires the use of a custom action. I have not tried it thoroughly, but it appears to jump you into a group across the battlefield. Seems like you could create a few actions to get you into the ground war quickly.

    http://alivemod.com/wiki/index.php/Script_Snippets#Jump_To_The_Action.21
    link text

  7. Friznit

    Jul 3 Administrator

    This is the same function that later board baked into the C2ISTAR module. Worth testing if it works standalone then it might be an issue with the module

  8. 2 weeks ago

    GunnyDev

    Jul 4 Administrator

    Fix committed, will be in next release after passing testing.

    https://github.com/ALiVEOS/ALiVE.OS/commit/149c8befb65559a872756d3499d333373528cc1e

 

or Sign Up to reply!