[Bug Discovered] Advanced Markers Autosave

  1. last year
    Edited last year by amahvan

    New update messed some stuff up? Advanced markers are no longer appearing and cannot be placed. The option does not even come up for any players in the server. Sitreps do not appear to persist, but player location seems to be working correctly. Battlefeed works most of the time, but not all the time.

    All of this worked until last night, then I updated to v1.4 and it stopped.

    War Room battlefeed also stopped updating (last update showing from yesterday): http://www.alivemod.com/war-room/showorbat/4674

    Maybe I'm doing something wrong? Feel free to log in and try it yourself: pass: jackrabbit

    RPT below:

    EDIT: It appears that a bug is present. When autosave is turned on (in this case, every 6 hours) Advanced markers will all be erased, and ALiVE confirmation popup & ALiVE map tab access will no longer appear, but the game and player positions will still load persistently.

    Disabling autosave in the module within the mission file appears to fix this problem.

  2. Edited last year by HeroesandvillainsOS

    Hmm regarding advanced markers they definitely do work with the new release. I've used them locally as host, and also as JIP on someone else's server with no issues. I wonder if deleting and replacing the ALiVE Required module will fix this for you? Pretty sure this is the module where you set the marker option (double check that) and that module was also updated to a new standard for 1.4.

  3. Thanks for the quick reply. I'm going to try that now. I hope the game keeps its persistence even with a mission file update.

  4. Turned out the mission file was somehow corrupted. I just re-exported the mission and changed the name and everything worked. I think it may have been related to the auto-save I have set for every 6 hours?

  5. Edited last year by amahvan

    I take it back. Not solved. Screenshot of chat: https://drive.google.com/file/d/0B0PAS352MV0AUXZUTXVzaDJFWUU/view?usp=sharing

    I think it may be the autosave feature?

    EDIT: Confirmed. It is the autosave feature causing the issue.

  6. @amahvan Can you make a ticket?


  7. Edited last year by amahvan

    @HeroesandvillainsOS I made the ticket. I have no idea why it's doing this. Still not loading markers even with autosave turned off now. It's honestly infuriating me at this point. Is it because players are joining the server after I server save and exit? Or does this feature just not consistently work? The war room also does not track our group's summary stats. It tracks everything in the white space (weapon usage etc) but it reads NaN hours of combat for group stats in yellow below the logo. (http://www.alivemod.com/war-room/showorbat/4674 )


or Sign Up to reply!