Issues with running ALiVE Linux Dedicated Server (AI) (Dependencies)

  1. 6 months ago

    Issues with running ALiVE on a Linux Machine.

    As stated above, I have tried running ALiVE on my Linux machine for the past few days to no avail. More specifically, what I mean is that ALiVE itself works, but it doesn't work well.

    When AI spawn in on the mission on the dedicated server, the AI spawned tend to just stand around, even when being ordered by the AI commander to move to a certain waypoint, etc...
    AI also tend to not have animations being used. When you attack an AI group, they face you but don't show any animations. It only shows the muzzle flashes from their rifles (which are being held at ease) and shoot you.

    I know for a certainty that the mission is setup correctly, because when I host on my Windows computer locally and play it, the AI move around and show animations (AKA: their Alive!)

    Please help if you can think of any solution to this problem. I guess it would help to mention that the Linux server is being hosted in a control panel, inside of it's own server container so maybe dependencies are missing or Alive uses peripheral assets that are not accessible within the container?

    Thank you!

  2. Deleted 6 months ago by Cunningham
  3. Update: Found this in the server files:

    23:44:08 ALiVE [m_0|30] Module ALiVE_sys_data INIT
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    Call extension 'ALiVEPlugIn' could not be loaded
    23:44:08 "THERE IS A PROBLEM WITH THE ALIVE PLUGIN!"
    23:44:08 ALIVE_SYS_DATA START PLUGIN: SYS_DATA_ERROR
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    Call extension 'ALiVEPlugIn' could not be loaded
    23:44:08 "THERE IS A PROBLEM WITH THE ALIVE PLUGIN!"
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    Call extension 'ALiVEPlugIn' could not be loaded
    23:44:08 "THERE IS A PROBLEM WITH THE ALIVE PLUGIN!"
    23:44:08 DATA: Attempting to load ALiVE web services config.
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    ERROR: ld.so: object '/libnss_wrapper.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
    Call extension 'ALiVEPlugIn' could not be loaded
    23:44:08 "THERE IS A PROBLEM WITH THE ALIVE PLUGIN!"
    23:44:08 ALiVE-0 CANNOT CONNECT TO CLOUD SERVICE, DISABLING WEB SERVICES
    23:44:08 DATA: Loading mission compositions data.
  4. @marceldev89

  5. Edited 6 months ago by marceldev89

    I don't know what OS/distro you're using but it's trying to load a 32 bit library from a 64 bit process so you'll have to figure out what package provides the 64 bit libnss_wrapper.so.

 

or Sign Up to reply!