Linux Dedicated Server Setup Issues

  1. 5 years ago

    Hi all,

    I'm new to ALiVE, but it looks awesome and I wanted to try this on my Linux Dedicated Server.
    I already had an Arma3 Server running fine, so I thought it would be simply installing another mod. But it seems that I was very wrong :(. After 4 hours of trying to get it running I need to ask you guys what I'm missing. And this is very frustrating for me as a Linux server admin...

    But never mind, here we go. I used the following guides to install the mod on the server:

    My steps were:
    #1 Download the latest version of alive from GitHub - which is the same as in the Steam Workshop
    #2 Extract and rename the folders to the following structure


    #3 putting those in my config


    #4 setting up the server on war room
    #5 placing the config in


    #6 making sure the libraries are linked correctly

    -> % ldd serverfiles/@aliveserver/ 
   => /usr/lib/i386-linux-gnu/ (0xf7c9e000)
   => /lib/i386-linux-gnu/ (0xf7b9c000)
   => /lib/i386-linux-gnu/ (0xf79c0000)
            /lib/ (0xf7f30000)
   => /usr/lib/i386-linux-gnu/ (0xf7997000)
   => /usr/lib/i386-linux-gnu/ (0xf7979000)
   => /usr/lib/i386-linux-gnu/ (0xf7959000)
   => /usr/lib/i386-linux-gnu/ (0xf794a000)
   => /usr/lib/i386-linux-gnu/ (0xf78dc000)
   => /usr/lib/i386-linux-gnu/ (0xf7681000)
   => /usr/lib/i386-linux-gnu/ (0xf762d000)
   => /usr/lib/i386-linux-gnu/ (0xf75cf000)
   => /usr/lib/i386-linux-gnu/ (0xf75bf000)
   => /lib/i386-linux-gnu/ (0xf75a0000)
   => /lib/i386-linux-gnu/ (0xf7581000)
   => /usr/lib/i386-linux-gnu/ (0xf7400000)
   => /usr/lib/i386-linux-gnu/ (0xf726a000)
   => /usr/lib/i386-linux-gnu/ (0xf7234000)
   => /usr/lib/i386-linux-gnu/ (0xf71f8000)
   => /usr/lib/i386-linux-gnu/ (0xf716d000)
   => /lib/i386-linux-gnu/ (0xf7168000)
   => /usr/lib/i386-linux-gnu/ (0xf708a000)
   => /usr/lib/i386-linux-gnu/ (0xf7055000)
   => /lib/i386-linux-gnu/ (0xf7050000)
   => /usr/lib/i386-linux-gnu/ (0xf7043000)
   => /lib/i386-linux-gnu/ (0xf702b000)
   => /usr/lib/i386-linux-gnu/ (0xf700d000)
   => /usr/lib/i386-linux-gnu/ (0xf6fc6000)
   => /usr/lib/i386-linux-gnu/ (0xf6e78000)
   => /usr/lib/i386-linux-gnu/ (0xf6e63000)
   => /lib/i386-linux-gnu/ (0xf6e5e000)
   => /usr/lib/i386-linux-gnu/ (0xf6e52000)
   => /usr/lib/i386-linux-gnu/ (0xf6db5000)
   => /usr/lib/i386-linux-gnu/ (0xf6d02000)
   => /usr/lib/i386-linux-gnu/ (0xf6cc6000)
   => /usr/lib/i386-linux-gnu/ (0xf6cae000)
   => /usr/lib/i386-linux-gnu/ (0xf6ca5000)
   => /usr/lib/i386-linux-gnu/ (0xf6c7b000)
   => /usr/lib/i386-linux-gnu/ (0xf6c6a000)
   => /usr/lib/i386-linux-gnu/ (0xf6c1b000)
   => /usr/lib/i386-linux-gnu/ (0xf6afd000)
   => /lib/i386-linux-gnu/ (0xf6ac9000)

    #7 placing the keys in ./serverfiles/keys/
    #8 starting the server, trying to connect

    Sadly now all my problems start. The server starts perfectly fine, without any issues as far as I can see.
    I can see the server in the server list and I can connect. However I cannot get the past the loading screen. It does not show any messages. It simply does not show the mission list as it used to before installing ALiVE.
    In the log I can see myself connecting, but I can never really get onto the server.
    The log states:
    Sorry I needed to move this to pastebin, because the forum did not let me create the post!

    To me it sounds like @aliveserver is not loaded somehow, becuase I've read about some alive log files (which I cannot see any) and it also does not have a hash in the mod list. Is this normal?

    Does anyone have a hint for me what is wrong or what I can do to make it work?

    If I disable @alive and @aliveserver I can connect just fine to the mission selection and the log is a bit different then:

     0:09:17 waterstorm uses modified data file
     0:09:19 BattlEye Server: Player #0 waterstorm (...:2304) connected
     0:09:19 Player waterstorm connecting.
     0:09:19 BattlEye Server: Connected to BE Master
     0:09:19 BEServer: registering a new player #1897321140
     0:09:21 BattlEye Server: Player #0 waterstorm - GUID: ...
     0:09:21 Player waterstorm connected (id=76561197963615480).
     0:09:21 BattlEye Server: Verified GUID (...) of player #0 waterstorm
     0:09:33 Admin logged in, player: waterstorm, playerUID: ..., IP: ...:2304.
     0:09:33 Admin logged in, player: waterstorm, playerUID: ..., IP: ...:2304.
     0:09:36 Mission Operation Landlord | ALiVE read from bank.
     0:09:36 Missing addons detected:
     0:09:36   alive_main
     0:09:36   alive_sys_profile
     0:09:36   alive_sys_data
     0:09:36   alive_sys_playeroptions
     0:09:36   alive_sys_weather
     0:09:36   alive_mil_opcom
     0:09:36   alive_mil_placement
     0:09:36   alive_civ_placement
     0:09:36   alive_mil_logistics
     0:09:36   alive_sup_player_resupply
     0:09:36   alive_sup_combatsupport
     0:09:36   alive_sup_cas
     0:09:36   alive_sup_transport
     0:09:36   alive_mil_c2istar
     0:09:36   alive_mil_cqb
     0:09:36 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.alive_main, alive_sys_profile, alive_sys_data, alive_sys_playeroptions, alive_sys_weather, alive_mil_opcom, alive_mil_placement, alive_civ_placement, alive_mil_logistics, alive_sup_player_resupply, alive_sup_combatsupport, alive_sup_cas, alive_sup_transport, alive_mil_c2istar, alive_mil_cqb

    Of course I could not start an alive mission then :-)

    Any hints are very appreciated! Thank you!

    PS: Please consider using Let's Encrypt certificates! I had a lot of issues simply creating the account at the war room because it's plain http.

  2. Edited 5 years ago by SavageCDN

    Hi Waterstorm,

    Your RPT on pastebin cuts off at about 60 lines - any chance you can post the entire RPT?

    -all pbo's are chmod 755
    -chmod +rw on the (owner is your linux user account for running arma 3)

    Just verifying both these steps have been completed.

    Also paging our resident Linux expert @marceldev89

  3. Edited 5 years ago by waterstorm

    Hi SavageCDN,

    thanks for the fast reply.

    Yes, the whole Arma 3 serverfiles folder belongs to the user and is 755. I also chmod(ed) the +rw.
    Sadly no luck there.

    Yes, of course, I do have the complete log on the server. Here it is:

  4. Weird that the RPT just stops like that... does the server freeze after you connect?

    From your RPT:

    Have you tried putting @aliveserver dir in the root /arma3 dir? (I am just guessing now :) )

  5. Edited 5 years ago by waterstorm

    /serverfiles is the root folder of the actual Arma 3 files :-)
    I'm using the LinuxGSM:

    Which has the steam executable and log files in /arma3/ and all actual server files in /arma3/serverfiles/
    So regarding the folders, this should fit ;-)

    I cut the first pastebin dump on upload accidentally.
    GSM automatically creates these log files for each server start. So I do have all the logs for each "try". At least in the format I have posted it.
    If you need any other additional info just let me know (and let me know how to create it).

    And no, the server runs just fine, I cannot see any problems. I can also connect a 2nd and 3rd time, without any luck :/
    But after a while the server shows the following in some of the log files:

     0:23:33 BattlEye Server: Player #0 waterstorm (...:2304) connected
     0:23:33 Player waterstorm connecting.
     0:23:33 BattlEye Server: Connected to BE Master
     0:23:33 BEServer: registering a new player #603345626
     0:33:03 NetServer::finishDestroyPlayer(446686035): DESTROY immediately after CREATE, both cancelled
     0:33:03 BEServer::finishDestroyPlayer(446686035): users.get failed

    So 10 minutes after the connect it shows some kind of "error"


  6. Ok thanks... gonna let Marcel have a go at this as my Linux-Fu is novice at best!

  7. Edited 5 years ago by SavageCDN

    OK Marcel's a bit busy today (apparently he works for a living... who knew???) but will take a look by tomorrow. Can you try with BattleEye disabled to see if that works?

    edit: also try removing all missions from the missions folder except the alive one you are testing

  8. Edited 5 years ago by waterstorm

    You are right... It is indeed BattleEye :/
    Damn, now I'm really bugged that I did not try that yesterday ;)

    However, this does not look like a good solution to me in the long run. Is this a known bug or is this a problem with my installation?

    I just tried to play a round with BattleEye disabled. I could connect, start and play successfully. (At least as far as I can tell from the 5 minutes test).

    Any recommendations what to do, to get BattleEye fixed?
    At least I can now play a round with some friends ;) Thanks a lot for the hint.

  9. Edited 5 years ago by SavageCDN

    fu*&^@$*(@&^#($&*ing BattleEye

    We've had some reports of servers not working (since the last A3 updates) and disabling BE fixed it.... other than that I'm not sure. BE doesn't do a lot on the server side of things other than ensure the client is running it. You could try re-installing BE from a fresh download...

    If you run a private server you could leave BE disabled and just run with signature checking... but if it's a public server no BE is suicide!

    BIS forums doesn't seem to have many complaints about BE not working.. sorry can't help much more than that :)

    We've asked the question in the A3 discord channel we'll see if anyone else has a suggestion.

    Just to confirm - your server loads OK with BE running but without @alive running? Can you test loading your mission with BE enabled, @alive enabled and WITHOUT loading @aliveserver?

  10. 8:22 PM] marceldev89: just to confirm my "iirc", BattlEye has been causing issues lately correct?
    [8:30 PM] Dedmen: yes. freeze at start
    [8:32 PM] marceldev89: just Linux or globally?
    [8:32 PM] Dedmen: linux
    [8:32 PM] Dedmen: symptoms same as when you reach open file limit

  11. Yeah ;) always a pleasure with BattleEye, Punkbuster and all the other nice tools :P

    I just tried a few things:
    #1 playing a normal mission with my standard mod set (CBA + VCOM) and BE enabled
    -> server load is pretty normal, ~50-80% load on one of the 4 cores and ~2 gb / 12 gb RAM used
    #2 playing with @alive but without @aliveserver and BE active
    -> I cannot connect, same problem as before, I simply cannot get past the loading screen
    #3 checking the open file limit
    it's pretty large on my root server ~1,2 million should be more than enough

    Usually we play with a few friends, so disabling BE should be no problem to get started with alive.
    But if you get more info or someone in the discord channel comes up with any solution please let me know :)

    Thank you for your help.

  12. It is quite weird that we seem to trigger it but I've really got no clue why. I imagine that if you load all the CUP mods etc it'll crap out as well.


or Sign Up to reply!