Really Need Help!!!

  1. 11 months ago

    Hey guys,

    Im super desperate here and at my end with this thing. So my linux server was working fine until I tried adding ips for the HCs to connect and added a custom profile I used on my old server to get custom difficulty working. Now the server won't load mods, I reverted back to the original state as I saved the original copies of the server.cfg and the profile but still broken. Havent touched any mods since its been working and havent touched my launch command but its still wont load mods. I have tried everything I cna think of but still it wont work and I dont know what else to do. Im using

    ./arma3server -name=server -config=server.cfg -mod="mods/@cba\;mods/@modpack\;mods/@rhsusaf\;mods/@rhsafrf\;mods/@taliban\;mods/@ace3\;mods/@alive\;mods/@jbad\;mods/@lythium\;mods/@projectopfor\;mods/@spyderaddons\;mods/@taskforceradio\;mods/@tfwradios\;mods/@bloodlust\;/@vcomai\;/@aliveserver"

    I have mods setup for armasync in the mod folder and the non cleintside ones outside of it, also I havent setup aliveserver for linux yet but It was working fine with that same command yesterday. I keep getting

    17:10:48 Warning Message: You cannot play/edit this mission; it is dependent on downloadable content that has been deleted.rhsusf_c_troops, ace_compat_rhs_usf3, ARD_Crye_Config, alive_main, alive_sys_data, alive_sys_playeroptions, alive_sys_profile, alive_sys_weather, alive_amb_civ_placement, alive_amb_civ_population, alive_mil_opcom, alive_mil_cqb, alive_mil_ied, alive_civ_placement, alive_mil_placement, alive_mil_logistics, amb_ambiance, civ_calltoprayer, civ_interact, rhsusf_c_weapons, rhsusf_c_mrzr, rhsusf_vehicles, rhsusf_c_HEMTT_A4, rhsusf_c_rg33, alive_sup_combatsupport, alive_sup_transport, alive_sup_cas, ace_advanced_ballistics, ace_advanced_fatigue, ace_advanced_throwing, ace_fastroping, ace_explosives, ace_hearing, ace_interaction, ace_map, ace_map_gestures, ace_microdagr, ace_nightvision, ace_finger, ace_respawn, ace_scopes, ace_tagging, ace_winddeflection, ace_repair, ace_rearm, ace_refuel, ace_medical, ace_medical_menu, tfar_core, po_main, ace_dragging, alive_mil_c2istar, UK3CB_BAF_Vehicles_LandRover,
    17:10:48 Mission BadghisTEST1.lythium: Missing 'description.ext::Header'

  2. then my desciption.ext thats missing a header looks like

    //Game Mode
    class header {
    gametype = COOP;
    minplayers = 1;
    maxplayers = 30;
    playerCountMultipleOf = 1;

    //Author and Loadscreen information
    author = "test"; //Author
    OnLoadName = "test"; //Mission Name
    OnLoadMission = "Test"; //Mission Description
    loadScreen = "test.paa"; //Preview picture

    respawn = BASE;
    respawnDelay = 3;

    //AI players
    disabledAI = 1;

    //Respawn Options
    respawnButton = 0;
    respawnOnStart = 0;

    class Extended_Init_EventHandlers {
    class Man {
    init = "_this call (compile preprocessFileLineNumbers 'my_script.sqf')";

  3. I also get spammed 17:46:00 Server error: Player without identity opendome (id ########)

  4. anyone who tries to connect gets Server error: Player without identity

  5. The server log might be useful to post here in full.

  6. Edited 11 months ago by HeroesandvillainsOS

    May also be useful to just run a test ALiVE + CBA only mission just to remove some variables though it sounds like this isn't a mod issue. I'd still recommend you do that for the sake of getting as quick of assistance on this as possible.

  7. As Heroes mentioned post the server RPT here for us to look at. I would also try re-installing A3 server on your dedi and creating a new profile. Try running with just one mod to see if that works (ie: CBA).

  8. 10 months ago

    Thanks guys! After a lot of messing around with it its working now.

  9. What's the fix?

  10. Welp with linux apparently you dont get rpts which blows so I tried doing a fresh reinstall, didnt help, tried reuploading all the mods, didnt help, then the update came out, updated to it then it worked lol

  11. Oh well that's nice. Magic! :)


or Sign Up to reply!