Problem with persistence not working

  1. 6 weeks ago

    Hey guys,

    I've already said this on the Discord (Moony here): I have the problem that the on my server the persistent save does not work. I don't really have experience with this so I'm fairly positive that I have done something wrong. Maybe you have an idea.

    To answer some questions:
    Yes, Data module is put down in the mission (set to local)
    Yes, modules are all set to persistence
    Yes, @AliveServer is loaded on the server

    Here you have the two log files:
    ServerRPT: https://pastebin.com/dEkdrTAG
    Aliveplugin: https://pastebin.com/rd6fsdYy

    You guys know better what to look for...
    I'm looking forward to your help.

    Many Greetings
    Moony

  2. Very interesting... it looks like the War Room related stuff works. At least my mission (With aar and stuff) is appearing in the War Room!

  3. local save should "Just Work™". Perhaps there's an issue when both local and war room are used. Can you try running it without @aliveserver?

  4. Nope did not do the trick aswell.

    New ServerRPT: https://pastebin.com/n1Xqb0Sg

    One thing change though: When I clicked "Save & Exit" before the ESC-Menu closed and nothing happened. This time the ESC-Menu stayed and nothing happened.

  5. Okay, got something now: Saving in Editor Multiplayer works just fine. (At least I hope) Does the persistent save also save Marker? Because it did not for me!

    Anyway, that obviously means...something is odd with my server, but what could it be?

  6. Sorry for the multiple answers here:

    Strange, so it can very well save. I just tried "5 call ALiVE_fnc_AutoSave_PNS" in the console and pushed server to execute. Seem to have worked. Reloading the mission and the building I purposely destroyed was still destroyed. So something is wrong with my ESC-Menu buttons!

  7. Hmmm I think I might have a similar problem, I logged in as admin and used server exit and waited until it finished saving everything. I then relaunched the server and the building I destroyed was no longer destroyed upon loading?

  8. Well not exactly the same Problem. For you its the other way around.

    Are you sure, that you launch the same mission (same mission name)?

 

or Sign Up to reply!