IEDs disappearing

  1. 8 months ago

    I made an insurgency on zargabad and everything is working well except that the IEDs that the insurgents put down all works in the beginning, but when you trigger one IED, all the other IEDs disappear from before. Is this supposed to happen?

  2. No lol that’s not intended. Can you duplicate with ALiVE and CBA only?

  3. @HeroesandvillainsOS No lol that’s not intended. Can you duplicate with ALiVE and CBA only?

    Here's a video of it happening:


    Also something I've noticed is that the game first spawns a VBIED in a vanilla car that can't be detonated when you pass by it, and it doesn't go away like all the other IEDs as shown above. I run CUP mods, RHSUSAF, ACE, Asr ai, and spyders addons. I'll try to remove ace and asr, but its hard since ace is so ingrained in the mission.

    Also side question: I have been having trouble with having units garrison my fobs. In the beginning, it all worked well, but I guess something must have happened because the friendly units don't get in buildings anymore.

  4. Edited 8 months ago by HeroesandvillainsOS

    Interesting. So that’s ALiVE’s IED/Asymmetric OPCOM debug showing there I assume? If so, do the IED’s actually disappear or is it just the debug markers?

    We’ve had a few IED reports. Nothing like this though. Thing is, although this video is awesome (so thanks for taking the time) I can almost 100% guarantee that unless you can duplcate with ALiVE and CBA only, this will not get looked into. Fortunately setting up a mission only takes a few minutes. Could you try?

    If discovered a specific mod, such as ACE, is actually the problem, that would be useful and it’s definitely still possible someone will try to solve it. Long story short, a reliable and to the point repro mission and report with steps to see, without the need for excess dependencies, is the best way of getting dev attention in my experience.

  5. Okay I did some testing. It appears that the problem is with the debug, but then theres more to that. So I made the mission with just Alive, CBA, and cup maps. The same issue happened with the debug going away, however, the IEDs are still in the game world. I went back to check it on the main mission, and I got the same result. So its just the debug not working. However, I encountered a 2nd problem. After the first IED goes off, the next IEDs that are still spawned in don't function right. I rolled over a dug in one, and ~10 seconds after I made contact, it went off. Same happened for the VBIED after setting off the first IED: the car de-spawned with white smoke, and left a clay charge on the ground, which took a while for it to go off.

  6. Edited 8 months ago by HeroesandvillainsOS

    Perfect. Can you open a ticket on our Github, provide this step by step info and post the stripped down repro mission?

  7. Here: https://github.com/ALiVEOS/ALiVE.OS/issues

  8. Ok I submitted a ticket

  9. Also one more thing, I've been looking at the RPT, and I keep seeing a reoccurring "count IED location: 0" What does that mean? When I tried to reproduce the problem, I kept running into issues where no IEDs where spawning in and I just restarted the mission.

  10. Not sure. Guess it couldn’t hurt to include the rpt file with the ticket and point that out. Might be the source of the problem; might not.

 

or Sign Up to reply!