Can't save in sp sessions

  1. 4 months ago

    Hello
    I am new to alive and I truly think it's an amazing platform, a real world changer.

    I built a mission, worked on it for a week or so to get all the specifics for a good resolution. I got so eager to play it, and now I am getting frustrated because I can't save the game. I clicked on the 'save' button and when I came back all the progress was gone. The same with the sample missions of alive team.
    I used all the modules exactly as instructed in the wiki and a few other guides.

    Do I have to open a server for saving? If so, (in the game) do I need to open a mp session and 0lay alone, or should I open a regular sp session? And, after saving with 'save server' (as I saw some suggestions in the forums with dedicated server) how would I open a server again with the same game progress after a day or so when I want to go back to the mission?

    Thanks a lot

  2. Edited 4 months ago by HeroesandvillainsOS

    There currently is an issue with saving progress on a local server, which is fixed internally, but this shouldn’t effect SP mode. My best guess is you set something up incorrectly.

    In the Data module, set saving to “local.” The default is “cloud” and will not work in SP. Also make sure to set “persistence” to “yes” in any module that allows it.

    Also, be advised, your player position at the time of saving is set to no by default. If you want your position to be persistent, set that to yes (I believe that one is in the player options module or something like that).

    If you’re still having issues, post the mission here (no mods outside of ALiVE and CBA, or minimal extras please) and I’ll take a look.

  3. Hi,

    I am not sure what exactly I should post...

    Do I need to post the 'mission.sqm'? and if so how do I upload the file?

    Sorry, I'm really new... :)

  4. @Messiah Hi,

    I am not sure what exactly I should post...

    Do I need to post the 'mission.sqm'? and if so how do I upload the file?

    Sorry, I'm really new... :)

    It’s ok. So still not working, eh?

    If the mission.sqm is the only file in the folder, yeah that’ll do if that’s what you want to post. But I generally just recommend people post the mission folder file itself (zip it up first) on Dropbox, then post the link for that here for me to DL.

  5. I hope that Google Drive link is fine as well...
    The mission.sqm file is all there is.

    here's the link:

    https://drive.google.com/file/d/1spwIs6RuhGK-sg9ITAH7UNB4dRJgl14w/view?usp=sharing

    Thank you very much. this is real support, I'm truly thankful.

  6. @Messiah

    Hey neat intro approach on that mission with the ride up and eject on mission start. :) In fact, I liked it so much and was bored, I made some edits for you (explained below):

    https://www.dropbox.com/s/vdnsdgajfo7hrff/SP_Save.Altis.zip?dl=0

    Ok so, the main problem was, you didn't have the Player Options module placed. In that module, you can set player position to be persistent (make sure it says yes), and you also have to have "save to database" I believe it's called, set to yes in that module also. I think what was going on here was, without this module placed in your mission, your player position wasn't saving, and that made it seem like nothing was loading. If that's not the case, let me know. Anyway, I added this module to your mission above so check it out!

    Other things I edited:

    I'm not an Air Commander expert or anything, but pretty sure you need to define that airspace. Anyway, I added that (blue "airspace" module, also written as an override in the Air Commander module).

    I added a small marker around your starting base to try and keep any friendly vehicle spawns from spawning directly in it. I named the "noexplode" and placed it directly above your little base, and added the marker name to the BLU Civ Obj Placement module blacklist.

    You had some vehicles exploding on mission start at the main base also, so I moved them. I also double clicked on both of your camo cargo net thingies and disabled their ability to take damage so they don't flatten like a pancake in the event you or you AI ever hit them or spawn ON THEM.

    I moved forward your spawn position because 100% of the time, the AI group following you in the vehicle to the base thingy on mission start, would crash in that town because Arma AI blows. Now they don't have to worry about hitting anything (though they still drive like madmen lol).

    I also removed your Unsung dependency. Now this mission ONLY REQUIRES ALiVE and CBA and nothing else. This leads me to believe maybe you made this mission on an Unsung map and didn't think of telling me (FOR SHAME!!! :) ) so now to punish you your mission is set on Altis. ;)

    It is saving for me, or at least it seems with a quick test. FYI if it doesn't for you, grab the new PBO with a persistence fix in this thread (it shouldn't apply to you here, but I was using it when testing your mission): http://alivemod.com/forum/4034-mission-not-saving

  7. Hey I'm having trouble with this as well. Before the recent update I could do the locally hosted server thing and save the game, but now whenever I press the admin save and exit thing nothing happens. I have my mission set to save local as well.

  8. First of all, problem solved so thank you very much!

    Thank you also for the other fixed in the mission I've learned a few things.

    Finaly I would like to ask, are you from the dev team? If you do, are there any plans or projects for the future?

    Thanks a lot!

  9. Edited 4 months ago by HeroesandvillainsOS

    @Seagull there is an issue with saving in a LAN environment using Local saving that’s fixed internally. Go to the link in my post above to the “mission not saving” thread, and grab the PBO Bradon linked for the test fix.

    @Messiah I am a “contributor” on the ALiVE team, also a moderator here. Basically that means although I do things for the mod and support for the community, I do non-coding stuff, but I guess you can say I am on the “team.” I also hang out in the dev Slack most days.

    Right now, with Arma being end of life, there are no major plans for ALiVE, aside from bugfixing.

 

or Sign Up to reply!