Deniland Index - Index was out of range.

  1. ‹ Older
  2. 7 weeks ago

    Same as before, just sits at Generating sector data, I left it for just short of an hour. Now I've actually done the categorization it wont load the UI anymore also which I think make sense cuz its found the static data etc. I tried changing the index settings to 'NO' but its the same in either, just sits there in the logs saying that. Anything else?

  3. marceldev89

    Aug 26 Moderator

    Well, at least there's some progress. ^^

    Send me the indexing folder so I can take a look at the output.

  4. Yeah its got somewhere at least.

    https://drive.google.com/file/d/1ov9dPpnkeVBIZhjRXBq_o5hrn_SQJRPV/view?usp=sharing

    hopefully that link works

  5. marceldev89

    Aug 26 Moderator
    Edited 7 weeks ago by marceldev89

    The static data generated by that UI thingy seems to be fine, it's just not doing it's thing after that. :/

    Did you turn off your antivirus and did you setup the scripts folder as pointed out on the wiki?

  6. AV is off and yep think so:

    C:\Users\<USER>\Documents\Arma 3 - Other Profiles\<ARMA3PROFILE>\missions\index.Deniland

    http://prntscr.com/kn2dgi

  7. marceldev89

    Aug 26 Moderator

    The scripts folder is supposed to be placed at "C:\Users\<USER>\Documents\Arma 3 - Other Profiles\<ARMA3PROFILE>\" and for good measure I guess "C:\Users\<USER>\Documents\Arma 3\" as well. :)

  8. It's already there to

  9. marceldev89

    Aug 26 Moderator

    Alrighty. I'll pass it off to someone in the team that's willing to give it a try using your static data UI output thingy and see if they run in to the same issue. I'll keep you updated if I have anything useful to tell. ^^

  10. Okay cool, thanks :)

  11. I've been letting it generate mil and civ clusters for about an hour now and it's still going. This is very unusual. It did end up finishing mil and moving onto civ though (where I am now) so we'll see. I'll let it run another hour or so and post back.

  12. Nah, never got past civ clusters. Sorry man, don't think this map can be indexed in this state but thanks for trying.

  13. Ok yeah no worries.

    Can I assume that other aspects of alive won't work such as AI virtualization? I.e. placing units down in Eden and trying to virtualize them?

  14. With an incomplete index I assume it won’t work with ALiVE at all but I guess I don’t know that for certain (IE what happens when civ/mil clusters aren’t generated).

  15. For the record I tried it and you are correct, it did not work :). Any way to trick it? I'd planned a large scale campaign on the map and was going to take full advantage of the AI virtualisation ALiVE has to keep numbers down.

  16. Best way really IMO is to determine what’s causing the index to fail after categorization. @marceldev89 any ideas why it’s failing?

  17. marceldev89

    Aug 28 Moderator

    In theory you could use a non-indexed map using custom objectives and/or placing down units and let them virtualize but that might be broken atm, not sure.

    As far why it's failing, I've got no clue. Maybe it's a map bounds thing?

  18. This map is odd in that the playable area (which is huge in itself) is only a small portion of the actual map. If you zoom back there is an unholy amount of empty non-playable grid. This is why I let the clusters try to generate for over two hours before I just gave up.

  19. @HeroesandvillainsOS yeah i noticed that to. Chernarus is similar though (albeit smaller) so i thought it'd be ok.

    @marceldev89 so i did try that actually. I set up a 'garrison' in a town with troops. The idea being theyd come in waves as the commander would be set to assault. So as we started taking our objectives (which would also be custom objectives) alive would see that and then try to re take them. The issue was though that the virtual AI module doesnt want to virtualise the the AI, when you play through, theyre all there on the map already. Can we assume that its broken?

  20. marceldev89

    Aug 29 Moderator

    Seems like it. ^^

  21. Ok, I'll get creative.

    Guys - thanks for all your help and patience on this. I guess consider this solved pending Virtual AI module getting fixed.

 

or Sign Up to reply!