[Solved] Dedicated Server not connecting

  1. 5 years ago

    Hey all,

    I am having an issue with connecting to the war room with one of my dedicated servers. It comes up with the cutlGet issue when trying to connect to the DB as seen below:

    [2018-10-01 20:02:53] [info] Checking WarRoom access...
    [2018-10-01 20:02:53] [info] URL: http://alivemod.com/api/authorise?group=SORD&localDB=false
    [2018-10-01 20:02:53] [info] WarRoom access granted.
    [2018-10-01 20:02:53] [info] Checking DB access...
    [2018-10-01 20:03:15] [error] ###### curlGet ######
    [2018-10-01 20:03:15] [error] Error: curl_easy_perform() failed
    [2018-10-01 20:03:15] [error] RAW: Couldn't connect to server

    I firstly built an Arma 3 server on my home PC and then connected to the war room following the instructions in the add a server section under group profile on the alive website. I created a simple mission and everything worked. The info appears in the war room and my stats updated.

    I then repeated the process on a dedicated server running Windows Server 2016 Standard. I used the same build process, creating a new server in the war room and used the same mission which I tested on my PC server earlier. No joy.

    I tried to connect to the database (http://db.alivemod.com:5984/) using firefox from my PC and everything looks normal. Comes up with the below:

    couchdb: "Welcome"
    version: "2.1.1"
    0: "scheduler"
    name: "The Apache Software Foundation"

    However, when I try the same process using both IE and Chrome on my dedicated server, it says "This site can't be reached.....".

    The dedicated servers firewall is turned off for testing, I have also added exceptions to Windows Defender for both the Arma server folder and the ALiVE folder in my appdata/local..... folder location.

    Does anyone have any ideas what is stopping the connection?

    aliveplugin text file >>> https://pastebin.com/dUzZT1E3
    Server RPT File >>> https://pastebin.com/TwuPQr1U



  2. Do you have Microsoft Visual C++ 2010 installed on the server?

  3. Edited 5 years ago by TPM

    @YonV Do you have Microsoft Visual C++ 2010 installed on the server?

    Yes, the same versions I am running on my home PC which also has Arma server installed and connected to the alive war room.

    I think the problem is that I am not able to hit http://db.alivemod.com:5984 as check via pasting this URL into a web browser. The only thing I can think of atm, is something on the providers ends. Like an Access Control List of something like that on the switch.

    • According to the logs there was a timeout while connecting to the database.
    • You've tried opening the link through IE/Chrome and it still didn't work.
    • I suppose your server is NOT hosted where your home PC is.

    Then your assumption is correct and the provider is most likely blocking this outgoing TCP port on their firewall. It's not uncommon.

  4. Edited 5 years ago by TPM

    I don't seem to be having much luck with my dedicated box provider, in saying that I think it is a routing issue as I can not ping the db.alivemod.com IP and trace route doesn't make it to the box.

    So I am looking at others ideas, one of which is to use a dynamic dns to redirect to to the correct address.

    This is what I get when I add our dyndns to the alive.cfg

    [2018-10-06 13:58:44] [info] ALiVEPlugIn v2.1a-
    [2018-10-06 13:58:44] [debug] >>> ParseMessage [StartALiVE ['true']]
    [2018-10-06 13:58:44] [debug] Function: StartALiVE
    [2018-10-06 13:58:44] [debug] Params:
    [2018-10-06 13:58:44] [debug] - [true]
    [2018-10-06 13:58:44] [info] Disable Performance Monitor: true
    [2018-10-06 13:58:44] [info] Reading 'alive.cfg'
    [2018-10-06 13:58:44] [info] Configuration found: C:\Users\ThePathMaker\AppData\Local\ALiVE\alive.cfg
    [2018-10-06 13:58:44] [info] Configuration 'alive.cfg' read OK.
    [2018-10-06 13:58:44] [debug] Alive Config:
    [2018-10-06 13:58:44] [debug] Type: JSON
    [2018-10-06 13:58:44] [debug] User: <removed>
    [2018-10-06 13:58:44] [debug] Pass: xxxxxxxxxxxxxxxx
    [2018-10-06 13:58:44] [debug] Group: SORD
    [2018-10-06 13:58:44] [debug] URL: http://<removed>.dyndns.org
    [2018-10-06 13:58:44] [info] Checking WarRoom access...
    [2018-10-06 13:58:44] [info] URL: http://alivemod.com/api/authorise?group=SORD&localDB=true --------------------<Unsure why this now says true>-------------------
    [2018-10-06 13:58:45] [info] WarRoom access granted.
    [2018-10-06 13:58:45] [info] Checking DB access...
    [2018-10-06 13:58:46] [error] ###### HandleMessage - StartALiVE ######
    [2018-10-06 13:58:46] [error] Error: JSON not a valid object
    [2018-10-06 13:58:46] [error] RAW:

    When this happens, the server crashes. When I place http://<removed>.dyndns.org into a web browser, it redirects correctly to the database. But it doesn't work from the alive.cfg file.

    Anyone got any ideas why this is happening?

  5. So has anyone used some type of dns or redirect to reach the db.alivemod.com url? If so, could you please share your knowledge.

    I so want to get this connection up and running, got some big plans for my gaming community.

  6. Can you do an nslookup from your server to db.alivemod.com and post the results?

  7. Deleted 5 years ago by TPM
  8. @YonV Can you do an nslookup from your server to db.alivemod.com and post the results?

    Server: google-public-dns-a.google.com

    Non-authoritative answer:
    Name: db.alivemod.com

  9. NSLookup looks fine, but you can't ping db.alivemod.com.
    There's either something on your end blocking db.alivemod.com , or db.alivemod.com is blocking you.

    It's just that simple.

    The plugin will not follow an http redirect so that will not work. You might have better luck with a transparent proxy. Google it.

  10. Who is your provider if you don't mind me asking? Where does your traceroute fail can you post the results here?

  11. Edited 5 years ago by TPM

    @SavageCDN Who is your provider if you don't mind me asking? Where does your traceroute fail can you post the results here?

    Provider is OVH. Is it possible that db.alivemod.com is blocking our connection? Our provider is asking this question.

    Here is the tracerout.


  12. As things stand, I am unsure if I am able to get our server to connect to the db.alivemod website.

    So I was wondering has anyone setup there own database that connected to their own website which kinda runs like the war room? Are there any guides or info on this? Any information would be awesome.

  13. Edited 5 years ago by TPM

    Also, while I was looking through the alivemod wiki, I noticed this "You can register an account to view Mission Stats whilst using Local persistence if you prefer."

    How does this work? Does the server still need to hit the db.alivemod.com ? Or does the stats info come from the client?

  14. Hmmm... I know groups have used OVH and War Room in the past with success so not sure what would have changed. AFAIK there are no specific blocks to the server but I will try to get an answer.

  15. Thanks Savage.

  16. Confirmed no blocking on the db side of things.

    From your traceroute your ping never leaves the OVH network (I assume the last entry is the 'exit point' from OVH), which is a bit odd... I would assume there would be a few hops between OVH and db.alivemod.com

    I know there was a problem like this a few years back (with Nitrado provider) but can't recall what (if any) was the resolution... have you opened a ticket with OVH yet?

  17. Thanks Savage. We have ticket open with OVH, but not really getting anywhere.

  18. You're welcome let me know if we can help.. maybe run some tests from our end, etc.

  19. This has now been resolved. Our IP was being blocked by armahosts.com. However their support centre was very helpful and resolved the issue nice and quickly. Thanks @SavageCDN for your help.

  20. Newer ›

or Sign Up to reply!