Having some issues with persistence (SOLVED)

  1. 6 years ago
    Edited 6 years ago by Exentenzed

    Started having some issues with persistence this evening.

    Started making a new mission yesterday, and set everything up for persistence after i had placed most of the vital alive modules, and i got it all working perfectly.
    Got the datapad up after clicking "Server save & exit" and it showed lots of info and then mission ended, could boot the mission back up again and everything had persisted.

    then i continued making the mission, made a few basic scripts that i needed, and populated the map with custom supplies and such for scavenging. Got everything ready, and proceeded to test it on the server again.

    This time however, nothing happens when i click "Server save & exit".
    I confirmed multiple times that i was logged in as admin, and the "Server exit" button works, which also requires admin.

    Also checked the war room, which confirms operation start.

    Double checked all modules to make sure persistence was turned on,
    Player logistics (disabled) module had "disable logistics" and "disable persistence" on "YES" which i turned back to "NO" and proceeded to try running it on the server again after renaming the mission, still didnt work.

    checked the RPT log and it confirms "ALiVE-0 CONNECTED TO DATABASE OK", but below that ends a few lines with "SYS_DATA_ERROR" and "ALiVE SYS_DATA - EITHER DATA LOAD FAILED OR MISSION DATA PERSISTENCE TURNED OFF: false" (both logs added + the mission folder itself in links below)

    aaaand now im at a loss of what is wrong.

    Any help would be greatly appriciated.

    Links to logs and mission
    Aliveplugin
    A3server.RPT
    Mission folder

  2. Are you using the latest version of CBA? If so, please note that persistence is broken until the next ALiVE update (soon™)

  3. Edited 6 years ago by Exentenzed

    Not a 100% sure, i downloaded CBA a few weeks ago, downloaded ALiVE on Thursday.
    I must have had some lucky timing then, because it worked flawlessly yesterday.

    I guess the only thing i can hope for at the moment is that (soon™) is (verysoon™). :D

    From what i did see yesterday i must say im very impressed with the persistence. Kudos! :)

    EDIT: im using the steam workshop to get CBA, which says it was last updated Febuary 20th. Meaning i used the same CBA version yesterday and it was working then. :)

  4. Friznit

    7 Mar 2016 Administrator

    Could be the mission data got corrupted. If you change the pbo name you get a fresh start.

  5. Edited 6 years ago by Exentenzed

    Thanks for the suggestion, tried renaming it 3 times yesterday, should have mentioned it on the OP.
    Not using a PBO though, just a regular folder.

    I will be trying to see if it decides to work today after making sure i rename both the mission folder AND the onLoadName. Will post update regardless.

    Additional question: How often do you wipe your DB? and does the wipes have any kind of schedule so it doesnt sneak up on us?

    Please dont misunderstand, i really appriciate the service you are offering us in addition to making this mod, im just curious. :)

  6. Edited 6 years ago by SavageCDN

    DB wipes are seldom. There has only been one to this date. The plan is to only delete mission data older than 6 months, so unless something changes in that regard, your (meaningful) data is never in much jeopardy.

  7. Ah, thats very reassuring. :)

    Well i did another test, same problem still after renaming everything relevant.
    the "Server Save & Exit" button does nothing.¨

    the RPT and aliveplugin where a bit different today though.

    Aliveplugin
    A3server.RPT

    Also came to think of the fact that i had it working at first, figured i'd include logs from the last time it actually worked for me. :) which was basicly that same day only early morning.

    Aliveplugin
    A3server.RPT

  8. Tried again, this time using CBA 2.2

    Still nothing.
    Starting to suspect that there is something i've done in the mission itself that borked it.
    Guess i'll have to wait until the next version to be sure.

    (If anyone that reads this and are using persistence at this time and has it working, could you please leave me a reply here? Thank you.)

  9. I mean if the only thing that changed between it working and not working was custom scripts and supplies, I would just remove them one by one and figure out which one caused the issue. If your scripts are in your mission root they should be super easy to just remove and put back in.

    Then post the offending bad-boy back here so we can burn it alive and never risk using it ourselves. LOL!

  10. Edited 6 years ago by Exentenzed

    Yup, solved it. Of course it had to be part of one of my own scripts that caused it to stop working, although i still have no idea why.

    One of my scripts require the following in the description.ext, and is what made me unable to initialize saving the server data trough clicking "Save server & exit"

    class CfgRemoteExec
    {        
    		class Functions
    		{
    			mode = 0;
    			jip = 0;
    			
    		};
    
    		class Commands
    		{
    			mode = 2;
    			jip = 0;
    			
    			class skipTime { allowedTargets=2; jip=0; }
    	};
    };

    Figured i'd share it here incase it could help the devs allowing this to be used in the future.

    its part of a day changing script that allows this

    (-daytime+6) remoteExecCall ["skipTime", 2];

    to be used via this

    this addAction ["Skip to Dawn", "timeScripts\setDawn.sqf"]

    Had 4 of those, one forEach dawn, dusk, day, and night.

    On the plus side, while extremely convenient for my mission, its not critical. And if people request the feature back, im sure i could set up a limited zeus for it, although it's not a very immersive way of doing it.

  11. Edited 6 years ago by SpyderBlack723

    Pretty sure defining CfgRemoteExec causes issues with other mods and scripts when used because it activates some protection setting which requires any used functions to be defined within CfgRemoteExec. There was another mod awhile back that used it and it basically destroyed any mod used in conjunction with it.

    Try posting your client rpt, there's probably some references to disallowed function calls.

  12. Edited 6 years ago by Exentenzed

    Here A3Client.RPT

    Not even sure what im looking for, but since you wanted it you can have it. :)
    that one is from earlier today, when i know i still had the problems.

    Seems like a big flaw though, i got the impression from reading about remoteExec and remoteExecCall, that it was supposed to be a faster and safer alternative to BIS_fnc_MP whenever it could be used.

  13. Can't see the error in there, but I do know that CfgRemoteExec can cause problems.

    You can use remoteExec and remoteExecCall without defining CfgRemoteExec. Just use them as you would any other scripting command.

  14. Edited 6 years ago by Exentenzed

    Yea, CfgRemoteExec had to be it, i even threw that into the description.ext without adding the addaction or sqf's into the mission. Just that alone caused the persistence to stop functioning completely.

    Oh... Well forgive me, as you probably could see im still rather new at this. I found CfgRemoteExec and saw the simplest way to do it, and got punished for it. :P

    Live and learn. ^^

    Thanks for all your tips and advice though (To everyone that responded in this thread). Much appriciated.

 

or Sign Up to reply!