Persistence Unable to Open Config File

  1. 4 months ago

    Having the following error in my persistence set up.

    I am running the server as a dedicated from the launcher on a mission using both EOS and ALiVE... I connected my player through the database and it says it reads the data but it will not put me in the same position or gear, I saved the mission as admin and re-entered and the mission was not saved either. The PDA was displaying "saving objects" etc. and took about 3-4 minutes to complete the saving completely before exiting the mission.

    Here is the snippet that I think might be causing the issue?

    [2017-04-10 00:08:53] [error] ###### ServerName ######
    [2017-04-10 00:08:53] [error] Error: Unable to open config file
    [2017-04-10 00:08:53] [error] RAW: ServerName

  2. Now I'm getting...

    [2017-04-10 02:34:57] [warning] ###### StartALiVE ######
    [2017-04-10 02:34:57] [warning] Warning: Already initialized
    [2017-04-10 02:34:57] [warning] RAW: StartALiVE ['false']

    and also this return error in many places. Any assistance would be appreciated, thanks.

    [2017-04-10 02:30:22] [debug] Return value [['ERROR']]
    [2017-04-10 02:30:22] [debug] |/-\ Elapsed time: 452.17ms
    [2017-04-10 02:30:22] [debug] >>> ParseMessage [SendJSON ['PUT','mil_cqb/WHI_Wolf Heart Industries MSO','{"_id":"WHI_Wolf Heart Industries MSO","index":["CQB_regular_0"]}']]
    [2017-04-10 02:30:22] [debug] Function: SendJSON
    [2017-04-10 02:30:22] [debug] Params:
    [2017-04-10 02:30:22] [debug] - [PUT]
    [2017-04-10 02:30:22] [debug] - [mil_cqb/WHI_Wolf Heart Industries MSO]
    [2017-04-10 02:30:22] [debug] - [{"_id":"WHI_Wolf Heart Industries MSO","index":["CQB_regular_0"]}]
    [2017-04-10 02:30:22] [debug] Return value [['']]
    [2017-04-10 02:30:22] [debug] |/-\ Elapsed time: 273.903ms
    [2017-04-10 02:30:23] [debug] >>> ParseMessage [SendJSON ['POST','sys_logistics/_bulk_docs','{"docs":[{"ASL_ID":"B_Slingload_01_Cargo_F_15342968","ASL_TY":"B_Slingload_01_Cargo_F","ASL_PO":[15342.1,968.389,-0.000999928],"ASL_VD":[[-0.865603,-0.500731,-3.94223e-008],[-6.77256e-008,3.83463e-008,1]],"ASL_CA":[[],[],[],[[[],[]],[["30Rnd_762x39_Mag_F"],[1]],[[],[]]],[]],"ASL_FU":1,"ASL_DA":0,"_id":"WHI_Wolf Heart Industries MSO-B_Slingload_01_Cargo_F_15342968"},{"ASL_ID":"RHS_MELB_MH6M_15397865","ASL_TY":"RHS_MELB_MH6M","ASL_PO":[15414.6,875.672,0.00734854],"ASL_VD":[[0.897522,0.44097,0],[4.74742e-005,-9.6626e-005,1]],"ASL_CA":[[],[],[],[[[],[]],[[],[]],[["FirstAidKit","ToolKit","ItemGPS","ItemRadio"],[4,1,1,1]]],[["Laserbatteries",1],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120]]],"ASL_FU":0.995407,"ASL_DA":0,"_id":"WHI_Wolf Heart Industries MSO-RHS_MELB_MH6M_15397865"}]}']]
    [2017-04-10 02:30:23] [debug] Function: SendJSON
    [2017-04-10 02:30:23] [debug] Params:
    [2017-04-10 02:30:23] [debug] - [POST]
    [2017-04-10 02:30:23] [debug] - [sys_logistics/_bulk_docs]
    [2017-04-10 02:30:23] [debug] - [{"docs":[{"ASL_ID":"B_Slingload_01_Cargo_F_15342968","ASL_TY":"B_Slingload_01_Cargo_F","ASL_PO":[15342.1,968.389,-0.000999928],"ASL_VD":[[-0.865603,-0.500731,-3.94223e-008],[-6.77256e-008,3.83463e-008,1]],"ASL_CA":[[],[],[],[[[],[]],[["30Rnd_762x39_Mag_F"],[1]],[[],[]]],[]],"ASL_FU":1,"ASL_DA":0,"_id":"WHI_Wolf Heart Industries MSO-B_Slingload_01_Cargo_F_15342968"},{"ASL_ID":"RHS_MELB_MH6M_15397865","ASL_TY":"RHS_MELB_MH6M","ASL_PO":[15414.6,875.672,0.00734854],"ASL_VD":[[0.897522,0.44097,0],[4.74742e-005,-9.6626e-005,1]],"ASL_CA":[[],[],[],[[[],[]],[[],[]],[["FirstAidKit","ToolKit","ItemGPS","ItemRadio"],[4,1,1,1]]],[["Laserbatteries",1],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120],["RHS_LWIRCM_Magazine_MELB",120]]],"ASL_FU":0.995407,"ASL_DA":0,"_id":"WHI_Wolf Heart Industries MSO-RHS_MELB_MH6M_15397865"}]}]
    [2017-04-10 02:30:23] [debug] Return value [['ERROR']]

  3. Edited 4 months ago by HeroesandvillainsOS

    Do you get errors or issues without MELB or EOD loaded? Is that the standalone MELB? Or did RHS adopt it?

  4. MELB? Not sure what MELB is, but no I haven't tried without mods. I haven't been able to find a stock alive map to run on it, would you happen to have a link to one so I can try it?

    I really need the mission to save with the mods as they're quite imperative, not entirely too concerned about player state saving.

  5. Kind of:

    https://www.dropbox.com/s/w7c1r3ua4i6bequ/ALiVE-Insurgency.Tanoa.pbo?dl=0

    Currently it requires ALiVE, CBA and Spyder Addons (which is made by ALiVE dev Spyderblack723).

    I will be releasing this with and without Spyder Addons soon but for now it requires it (it will work just fine on a server and will be a good test mission to see what's going on).

  6. :/ I just realized the mission you sent is Tanoa... I don't have the arma 3 expansions. :[

  7. 3 months ago

    I'm really confused by this... I'm not getting any errors on the log, just DEBUG's all the way through, and the war room website IS tracking the data on player kills, locations, etc., it even tracks player locations gear etc. when logging back in if I don't restart the mission or server, however when I restart the mission (after doing admin exit and save), the mission doesn't save, and any restart of the server or mission deletes the player data and they start back fresh.

    Thoughts?

  8. You may want to debug the ALiVE Data module, attempt a save, and post your server rpt back here for a dev to look at.

  9. Okay will do, I'll attempt to get it up tomorrow...drop box?

  10. Dropbox is good.

  11. So... yeah... strange issue... When I turn on the debug and attempt to connect to my server (tested with multiple clients) we all get stuck at loading 100%, we can hear in game sounds but can't get in. if I disable debug we load in just fine. Thoughts?

  12. You should still post the server rpt back here for a dev to look at. Although I doubt it's mod related, probably best to send over a rpt without any other mods running just so it's as clean as possible.

    ALiVE CBA only.

  13. Isn't the report only generated when I do a server save and exit? I literally can't get into the mission with the debug on. Also where is the report saved to?

  14. Okay checked some of them (I think these are the ones when I had debug clicked on)

    [2017-05-01 18:33:18] [info] ALiVEPlugIn v2.1a-
    [2017-05-01 18:33:18] [debug] >>> ParseMessage [StartALiVE ['false']]
    [2017-05-01 18:33:18] [debug]     Function: StartALiVE
    [2017-05-01 18:33:18] [debug]     Params:
    [2017-05-01 18:33:18] [debug]             - [false]
    [2017-05-01 18:33:18] [info]     Disable Performance Monitor: false
    [2017-05-01 18:33:18] [info]     Reading 'alive.cfg'
    [2017-05-01 18:33:18] [info]     Configuration found: C:\Users\Administrator\AppData\Local\ALiVE\alive.cfg
    [2017-05-01 18:33:18] [info]     No URL in config. Using default.
    [2017-05-01 18:33:18] [info]     Configuration 'alive.cfg' read OK.
    [2017-05-01 18:33:18] [debug]     Alive Config:
    [2017-05-01 18:33:18] [debug]         Type:  JSON
    [2017-05-01 18:33:18] [debug]         User:  irizehigu4i7ycuginegowiko3etebyp
    [2017-05-01 18:33:18] [debug]         Pass:  xxxxxxxxxxxxxxxx
    [2017-05-01 18:33:18] [debug]         Group: WHI
    [2017-05-01 18:33:18] [debug]         URL:   http://db.alivemod.com:5984
    [2017-05-01 18:33:18] [info]     Checking WarRoom access...
    [2017-05-01 18:33:18] [info]     URL: http://alivemod.com/api/authorise?group=WHI&localDB=false
    [2017-05-01 18:33:18] [info]         WarRoom access granted.
    [2017-05-01 18:33:18] [info]     Checking DB access...
    [2017-05-01 18:33:18] [info]         DB access granted.
    [2017-05-01 18:33:18] [info]     ALiVE successfully initialized.
    [2017-05-01 18:33:18] [debug]     Return value [['StartALiVE','OK','Performance Monitor: Enabled']]
    [2017-05-01 18:33:18] [debug] |/-\ Elapsed time: 884.264ms
    [2017-05-01 18:33:18] [debug] >>> ParseMessage [ServerAddress]
    [2017-05-01 18:33:18] [debug]     Function: ServerAddress
    [2017-05-01 18:33:18] [debug]     Params:
    [2017-05-01 18:33:18] [info]     ServerAddress - Querying for IP @ ipify.org
    [2017-05-01 18:33:19] [info]         IP returned: 209.126.104.85
    [2017-05-01 18:33:19] [debug]     Return value [['209.126.104.85']]
    [2017-05-01 18:33:19] [debug] |/-\ Elapsed time: 78.759ms
    [2017-05-01 18:33:19] [debug] >>> ParseMessage [GroupName]
    [2017-05-01 18:33:19] [debug]     Function: GroupName
    [2017-05-01 18:33:19] [debug]     Params:
    [2017-05-01 18:33:19] [info]     GroupName: WHI
    [2017-05-01 18:33:19] [debug]     Return value [['WHI']]
    [2017-05-01 18:33:19] [debug] |/-\ Elapsed time: 0ms
    [2017-05-01 18:33:19] [debug] >>> ParseMessage [SendJSON ['GET','sys_data/config','']]
    [2017-05-01 18:33:19] [debug]     Function: SendJSON
    [2017-05-01 18:33:19] [debug]     Params:
    [2017-05-01 18:33:19] [debug]             - [GET]
    [2017-05-01 18:33:19] [debug]             - [sys_data/config]
    [2017-05-01 18:33:19] [debug]             - []
    [2017-05-01 18:33:19] [debug]     Return value [['{"_id":"config","_rev":"31-87c1a041c4c198f488f7302f15e2ab94","On":"true","EventLevel":5,"PerfData":"true","EventData":"true","MissionData":null,"AAR":"true"}
    ']]
    [2017-05-01 18:33:19] [debug] |/-\ Elapsed time: 458.953ms
    [2017-05-01 18:33:19] [debug] >>> ParseMessage [SendJSON ['GET','sys_data/dictionary_WHI_Wolf Heart Industries MSO','']]
    [2017-05-01 18:33:19] [debug]     Function: SendJSON
    [2017-05-01 18:33:19] [debug]     Params:
    [2017-05-01 18:33:19] [debug]             - [GET]
    [2017-05-01 18:33:19] [debug]             - [sys_data/dictionary_WHI_Wolf Heart Industries MSO]
    [2017-05-01 18:33:19] [debug]             - []
    [2017-05-01 18:33:19] [debug]     Return value [['']]
    [2017-05-01 18:33:19] [debug] |/-\ Elapsed time: 264.239ms
    [2017-05-01 18:33:23] [debug] >>> ParseMessage [SendJSON ['GET','sys_profile/WHI_Wolf Heart Industries MSO','']]
    [2017-05-01 18:33:23] [debug]     Function: SendJSON
    [2017-05-01 18:33:23] [debug]     Params:
    [2017-05-01 18:33:23] [debug]             - [GET]
    [2017-05-01 18:33:23] [debug]             - [sys_profile/WHI_Wolf Heart Industries MSO]
    [2017-05-01 18:33:23] [debug]             - []
    [2017-05-01 18:33:23] [debug]     Return value [['']]
    [2017-05-01 18:33:23] [debug] |/-\ Elapsed time: 270.939ms
    [2017-05-01 18:33:38] [debug] >>> ParseMessage [SendJSON ['GET','mil_cqb/WHI_Wolf Heart Industries MSO','']]
    [2017-05-01 18:33:38] [debug]     Function: SendJSON
    [2017-05-01 18:33:38] [debug]     Params:
    [2017-05-01 18:33:38] [debug]             - [GET]
    [2017-05-01 18:33:38] [debug]             - [mil_cqb/WHI_Wolf Heart Industries MSO]
    [2017-05-01 18:33:38] [debug]             - []
    [2017-05-01 18:33:39] [debug]     Return value [['']]
    [2017-05-01 18:33:39] [debug] |/-\ Elapsed time: 281.45ms
    [2017-05-01 18:33:52] [debug] >>> ParseMessage [SendJSON ['GET','mil_cqb/WHI_Wolf Heart Industries MSO','']]
    [2017-05-01 18:33:52] [debug]     Function: SendJSON
    [2017-05-01 18:33:52] [debug]     Params:
    [2017-05-01 18:33:52] [debug]             - [GET]
    [2017-05-01 18:33:52] [debug]             - [mil_cqb/WHI_Wolf Heart Industries MSO]
    [2017-05-01 18:33:52] [debug]             - []
    [2017-05-01 18:33:52] [debug]     Return value [['']]
    [2017-05-01 18:33:52] [debug] |/-\ Elapsed time: 258.204ms
    [2017-05-01 18:33:53] [debug] >>> ParseMessage [ServerName]
    [2017-05-01 18:33:53] [debug]     Function: ServerName
    [2017-05-01 18:33:53] [debug]     Params:
    [2017-05-01 18:33:53] [info]     Config file: C:\Program Files (x86)\Steam\steamapps\common\Arma 3\ RHS config;C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\@BlastCore Phoenix 1.2;C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\@BloodLust;C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\@CBA_A3;C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\@CUP ACE3 Compatibility Addon 
    [2017-05-01 18:33:53] [error] ###### ServerName ######
    [2017-05-01 18:33:53] [error]     Error: Unable to open config file
    [2017-05-01 18:33:53] [error]     RAW:   ServerName
    [2017-05-01 18:33:53] [debug]     Return value [['ServerName','ERROR','Unable to open config file']]
    [2017-05-01 18:33:53] [debug] |/-\ Elapsed time: 0ms
  15. I don't know how to read these but do you have alive.cfg in your Arma root folder?

  16. Yes,
    Contents:

    # ALiVE War Room config
    JSON,irizehigu4i7ycuginegowiko3etebyp,o9aza6yxu9ydufajazofu9yry4eja8el,WHI
  17. SavageCDN

    May 3 Moderator

    If you are running Windows on the server make sure your alive.cfg file is unblocked - right click on the file and select Properties. If it is blocked there will be a button on that tab to unblock.

  18. Edited 3 months ago by marceldev89

    @Pliskin124 [2017-05-01 18:33:53] [debug] >>> ParseMessage [ServerName] [2017-05-01 18:33:53] [debug] Function: ServerName [2017-05-01 18:33:53] [debug] Params: [2017-05-01 18:33:53] [info] Config file: C:\Program Files (x86)\Steam\steamapps\common\Arma 3\ RHS config;C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\@BlastCore Phoenix 1.2;C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\@BloodLust;C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\@CBA_A3;C:\Program Files (x86)\Steam\steamapps\common\Arma 3 Server\@CUP ACE3 Compatibility Addon [2017-05-01 18:33:53] [error] ###### ServerName ###### [2017-05-01 18:33:53] [error] Error: Unable to open config file [2017-05-01 18:33:53] [error] RAW: ServerName [2017-05-01 18:33:53] [debug] Return value [['ServerName','ERROR','Unable to open config file']] [2017-05-01 18:33:53] [debug] |/-\ Elapsed time: 0ms

    This error is related to the server.cfg file that's loaded with the -config= parameter and not the alive.cfg file. Try renaming @RHS config to something without the word config or move the -config= parameter before the -mod line. There's a little bug in the ALiVE server DLL where it detects the wrong config word in the command line. :)

  19. @SavageCDN If you are running Windows on the server make sure your alive.cfg file is unblocked - right click on the file and select Properties. If it is blocked there will be a button on that tab to unblock.

    File has always been unblocked, thanks though.

    @marceldev89 This error is related to the server.cfg file that's loaded with the -config= parameter and not the alive.cfg file. Try renaming @RHS config to something without the word config or move the -config= parameter before the -mod line. There's a little bug in the ALiVE server DLL where it detects the wrong config word in the command line. :)

    I am currently using the Arma 3 Launcher to launch the game, I tried using the dedicated server however performance seemed worse and ALiVE still didn't work. I don't see config at the end of @RHS? All I have is
    "@RHSAFRF","@RHSGREF","@RHSSAF","@RHSUSAF"

    However when I was using the server.exe through a batch file my -config and -cfg were always well before the -mod line.

  20. Oh wait, it looks like its ASR AI3 - RHS Config.. found it now, changing.

  21. Newer ›
 

or Sign Up to reply!