ORBAT-faction empty inventory on dedicated server.

  1. 3 weeks ago
    Edited 3 weeks ago by McNools

    Hello, I've recently started the finishing touches of a campaign I'm making for my group, I've made a custom-faction for our enemy using the ORBAT-tool. However, when testing the mission on our dedicated server, all the units spawned by alive (not those placed in the editor or spawned by zeus) have completely empty uniforms/vests/bags. They still seem to get ammo and grenades since they reload and keep firing even if I control a unit in zeus and empty their magazine and then stop controlling them.

    When trying the mission in SP/non-dedicated multiplayer (hosting it myself) all units spawned by Alive have their uniforms/vests/bags packed with the correct loadouts.

    Is this some sort of intentional function to reduce server-load or is it a bug? and if so, has anyone had the same problem and know how to fix it?

    Here's a link to the unpacked .pbo with the faction config:
    http://s000.tinyupload.com/index.php?file_id=02614724324533291815

    EDIT: just to be clear, they all spawn with the correct weapons, uniforms, vests etc. It's just that they're all completely empty.

  2. Friznit

    Jul 2 Administrator

    This is a known "feature". It's nothing deliberate but I believe it's actually a BIS bug with the locality of one of the commands use to equip units.

  3. ok! then at least it doesn't break anything else etc.?

  4. Friznit

    Jul 3 Administrator

    It all works, you just can't steal stuff off dead enemy. It's on the backlog for a fix sometime

  5. Ok! thanks! I suppose I'll have to train my trigger-happy friends to conserve their bloody ammo... Haha

  6. 2 weeks ago

    The AI can still use the gear. The gear exists on the server, but not on the clients. Confusing, but it should work fine. We've added a ticket for BIS to look at, but it's clear that no response will come quickly.

 

or Sign Up to reply!