AliVE and R3F Logistics/Persistence

  1. last year

    Hi everyone!

    I would like to get R3F logistics working with ALiVE persistence and found this

    http://alivemod.com/wiki/index.php/Logistics_Support

    when it says "Place the Alive (Required) module as normal but name it ALiVE_SYS_LOGISTICS" do you place two ALiVE (Required) modules with one named ALiVE_SYS_LOGISTICS or do you just rename the original module ALiVE_SYS_LOGISTICS?

    Thanks!

  2. when I name the module (either by itself or with another required module) I get only one player logistics module allowed

  3. Just one module the "ALiVE_SYS_LOGISTICS" should go in the Name field in the module settings. Also make sure you adjust the R3F script as described on the wiki link.

  4. Thanks! I tried having one ALiVE (required) module on the map and putting ALiVE_SYS_LOGISTICS in the variable name but when I start the mission I get a big red box that says

    only one player logistics module allowed

  5. Hmmm.. can you post your RPT file for us to look at?

  6. For sure here it is

    RPT

    Thanks!

  7. Nothing obvious to me in the RPT file.. you're SURE you only have one module placed? Try deleting it and re-placing?

    If no go try a simple vanilla mission (CBA and ALiVE with R3F) and see if you get the same error... just to rule out any issues with other mods.

  8. Yup I double checked and just have the one. As soon as I remove the name the error goes away though. I also just launched CBA/ALiVE/R3F and made a mission on Stratis with the same error.

  9. Thanks.. any chance you can send me a copy of that test mission (CBA/ALiVE/R3F)? I'll open a ticket on github and it will get looked at.

  10. highhead

    9 Nov 2017 Administrator

    By theory putting that line with the "updateObject" operation in R3F should suffice totally. I would not rename ALiVE_required to ALiVE_SYS_LOGISTIC - it will mess things up!

  11. Thanks that seems to have worked perfectly!

  12. Thanks for confirming I will update the wiki

  13. One sort of odd thing is that if the Combat Support vehicles are used for transporting items the vehicle without crew seems to save where it landed last. I tried putting

    this setVariable ["R3F_LOG_disabled", true];

    in its init to disable it from being apart of the R3F logistics system but it doesnt seem to disable it.

  14. I got it working locally with

    this setVariable ["R3F_LOG_disabled", true]; in the code field of the transport module which works when I host locally but when I put in on the dedicated server it doesn't work?

 

or Sign Up to reply!