Error Undefined Variable in expression: _profileid

  1. 9 months ago
    Edited 9 months ago by Preacher

    I dearly apologize if this post is misplaced. I searched the forums for the error in hopes someone else encountered and found a solution, but no luck.

    I'll spare you the "i'm new" bull and cut to the chase. I'm having this issue and have no idea how to fix it. I tried copying a buddies task handler file and replacing my own, but this did nothing. I've repaired the mod, uninstalled the mod, reinstalled the mod, chucked my PC out the window and put it back together again.

    Everything was fine and dandy last night, but now all of the sudden auto tasking has completely stopped. Zooming around in Zeus shows that there are enemies spawning around the map, but the Player Command module is not doing it's job.

    This is the initial error given when the task handler usually does it's thing:
    -image-

    This is the code given after replacing the file with my buddies.
    -image-

    I do apologize for coming off as ignorant. I literally spent my entire friday trying to figure out why auto tasker wasn't working. And since I'm not a programmer, I just couldn't figure it out.

    I reiterate, I had everything working perfectly last night and was actively playing with a buddy in my mission.

    I'm absolutely horrible at using forums, so don't be scared to DM me via steam; I have bookmarked this post, and followed it for email notifications. I'm not looking for someone to fix it for me, I'm glad to fix it myself if someone can walk me through it so to understand (I realize that's pretty much the same thing). But it seems every time I ask for help in the code/script department I'm met with a lot of opposition, almost scared to ask questions anymore.

    If it would help that I provide a .pbo, just let me know here, or HMU on steam @ CPL.Preacher .

    Many thanks for this great addition to my arma experience. I'd be (am) lost without it.

    Sincerely, Preacher.
    Email: nobrostudios@gmail.com

  2. Can you host the screenshots of the errors on imgur.com ?

  3. Edited 9 months ago by Preacher

    I tried to register on imgur so I could share, but it's telling me I'm moving too fast :/ Dropbox?

  4. I'm no programmer, but I spent all week developing this mission in hopes to have it up by tonight so I could share it with the fellas; so I downloaded arma editor cuz that's what google told me to do. Turns out Arma editor just shows me a bunch of mumbo jumbo when I open that .sqf file.

  5. Deleted 9 months ago by Preacher
  6. Are you the only one in when this happens? What is your in-game Arma name.

  7. Edited 9 months ago by Preacher

    My ingame ARMA name is CPL.Preacher. Nah, my father in law was with me, but i'm the only one who gets it. I host dedicated off my server. I can launch it if you like? It's on Isla Abramia V3.9 though

  8. Deleted 9 months ago by Preacher
  9. Any site isn’t fine, it’s just the photobucket site is only letting you see the images. Can you use another site? The images are all saying your photo bucket account doesn’t allow 3rd party hosting on my end (I can’t see the screenshots).

  10. Deleted 9 months ago by Preacher
  11. Deleted 9 months ago by Preacher
  12. Updated OP. Should work? I used some hosting site called tinypic

  13. Edited 9 months ago by HeroesandvillainsOS

    Yeah it works now. Spyder is probably the guy to diagnose the exact error, but I’m looking for clarification in the OP. So you’re using a custom task handler? Assuming to generate or track tasks, and not just the built in C2ISTAR auto tasking as is without custom changes? Can you paste whatever that script/code is here and post what you’re trying to accomplish with your buddy’s file?

  14. Negative. I'm just using the built in C2ISTAR module.

    Rabbit was able to fix my errors, but I'm not yet sure how (he's afk). I haven't been paying any attention to A3 updates, so he thinks there was an update and the map I was using is causing the autotasker to fail. Isla Abramia v3.9

    This is the only thing I could think might be getting in the way of the C2ISTAR module. Because it was all working fine and dandy two days ago.

    Once I know how he fixed it, I'll report back here and try to elaborate on what was causing the error.

  15. Ah ok. Yeah I’m thinking it’s possible Icebreakr’s maps have all broken (for ALiVE purposes) and need a new index since he updated them not long ago. Reports are the index is messed up on Isla Duala, so Isla Abramia is likely in the same boat. I’d advise to try using maps not made by him if the problems continue or come back, until we can get fresh indexes out (or unless someone else does them).

  16. I was reading up on how to index maps. The process seemed a bit out of my league, but i'll see what I can do if it'll help the ALiVE community. All the hard work ya'll put into this mod enables nubs like me to make fun experiences, and that's pretty cool.

  17. That would be cool if you could try. I handle a good portion of the indexing recently, along with a couple others, but had an issue with my PC and haven’t gotten around to reinstalling the tools after installing my OS again. If you do try it that would be great and we can help you if you get stuck or have questions.

  18. I read the wiki on indexing. Either i'm about the dullest tool in the shed, or I just need more sleep before I can figure it out. I really am interested in doing this to help everybody, because the map is truly a great map, it's just going to take me a bit to understand the process.

  19. Getting set up is the hardest part, but it’s really not that hard, it’s just the step by step is definitely a bit intimidating the way it’s written. The actual indexing part is pretty easy once you get going.

    If you do take a stab at getting started, it’s ok to ask for help or clarification.

  20. I have disabled Battleye.
    I don't use any AV.
    I have created an "ALiVE" folder in the @ALiVE folder in the ARMA3 !workshop directory.
    The ALiVE.ddl and the alive_object_blacklist.txt are both present.
    I have downloaded Mikero's tools, and copied the files to C:Windows System 32.
    I have downloaded the scripts and copied the folder to ARMA 3.
    I have downloaded Baretail, and loaded the latest ARMA3.rpt file (I have a bunch of them?)
    I have right click ARMA3 on steam and set launch properties to "-mod=@ALiVE; @CBA_A3; @Isla Abramia 3.9 -filePatching"

    Presuming I've done this all correctly, I'll update you on the rest. I'm doing this as I type.

  21. Newer ›
 

or Sign Up to reply!