Server save and exit not working

  1. 6 days ago

    Hey guys,

    I've attached my RPTs and the modline is listed below. We've been running for about 2 weeks now but I can't seem to figure out why the server save and exit button does not work. Successfully linked to War Room and I see the DB connects successfully. However our server restarts everyday and we noticed that the persistence has not gone through. Been trying to figure it out for the better part of a week but still haven't found anything.

    Tried updating server alive version
    Tried reuploading aliveserver to the dedicated server on ArmaHosts
    Tried a different mission (Clafghan) from our current mission on Malden still no joy. Even rebuilt the mission from scratch to see if that would work.

    Any help would be greatly appreciated.

    client mods:
    @=ATM=Altimeter;@ace;@ACE_Comp_RHS_AFRF;@ACE_Comp_RHS_USAF;@acex;@ADV-ACE_CPR;@BoxLoader;@cba;@CUP_Terrains_Core;@CUP_Terrains_Maps;@Enhanced_Movement;@ILBE;@ILBE-Fix;@RHS_AFRF;@RHS_USAF;@ShackTac_UI;@Task_Force_radio;@VIS;@VSM_Accessories;@VSM_Uniforms;@VSM_VestsnHelmets;@NIArms_AIO;@Ctab;@CUP_Terrains_CWA;@Ares_Achilles;@Chestpack;@Cigs;@Nimitz;@USSOC_LITE_mas;@FIR_AWS;@F-15;@22nd_Maps;@Project_OPFOR;@Alive

    server mods:
    @Advanced_Rappelling;@Advanced_Sling_Loading;@Advanced_Towing;@Advanced_Urban_Rapelling;@aliveserver

    latest rpt:
    https://www.dropbox.com/s/8hziuzugtobt9en/arma3server_x64_2018-02-11_21-49-04.rpt?dl=0

    It should also be noted that we do have a headless client that we turn on from time to time, not sure if this affects anything.

    Thanks!
    - Shifty

  2. 5 days ago
    Edited 5 days ago by HeroesandvillainsOS

    I’m sure you missed the announcement, but War Room will be closing at the end of the month. Unfortunately you’re not going to get support on this specific issue because in a couple weeks you won’t be able to use War Room anyway.

    Change the saving type to local in the Data module and see if the problems continue and report back if so.

  3. Gotcha, thanks for the reply man. I didn't see the announcement, will move to local db saving. Will we still be able to have MSOs with local saving? From my understanding (please correct me if I'm wrong) war room was required for persistence across server restarts?

  4. SavageCDN

    Feb 12 Moderator

    Local saving should work across server reboots.

  5. 4 days ago

    Tried updating, server persistence still not working locally. Verified ALiVE version and everything, can post rpts at request, just unsure which one to post now.

  6. The server is where the work is being done so that RPT would be good. It should just work™ though.

  7. https://www.dropbox.com/sh/n0dywr9pm7ytp81/AABrP-v0KE5XfILFnWkz337ca?dl=0

    Thats the link to the folder i placed our last few RPTs in. Seemed to be loading this morning but now it doesn't work again. Should I still run the @aliveserver?

    Sidenote would you happen to have a local saving setup screenshot of the Alive Data Module? Maybe thats messing it up? I only changed it from cloud to local since then...

  8. Edited 4 days ago by marceldev89

    All of the RPTs have the message "ALiVE SYS DATA PNS - Local machine is not the server or local save not available! Exiting...", interesting. You seem to be using the autosave functionality and calling that function from a client instead of the server. Try using the "old fashioned" way with the server save & exit button.

    Switching the module to local should be all you'd need to do.

    Also it looks like you have multiple data modules placed down, not a big deal but just saying.

  9. Had it in the init, will test now with no autosave, should i still run the @aliveserver mod as well?

  10. Edited 4 days ago by M.Shifty

    https://www.dropbox.com/s/n6w3j1jbrzlem6o/arma3server_x64_2018-02-13_19-30-57%20%281%29.rpt?dl=0

    New RPT

    Removed the autosave feature but it still doesnt seem to be working

  11. Update: sorry for the spam, the server save and exit button now works but the mission still does not load whatever is saved (adv markers dont show up on restart)

  12. 3 days ago
    Edited 3 days ago by marceldev89

    I believe @aliveserver is only required for a connection to the War Room so I guess you can run without it. It shouldn't affect anything if you keep it loaded though.

    There have been some reports that advanced marker persistence didn't work but I don't think it has been reproduced as of yet (https://github.com/ALiVEOS/ALiVE.OS/issues/439 ). If you can verify that persistence is working for all the other systems (i.e. profiles, objectives, tasks perhaps) then it should be all good and the advanced markers would then be a separate issue. The RPT doesn't seem to be showing any problems.

  13. Hey Marcel,

    I see the following error in both the latestrpts

    ALiVE-0 CONNECTED TO ALIVEMOD.COM , BUT CLOUD SERVICE HAS BEEN TURNED OFF
    8:32:40 ALiVE-0 EXITING DATA INIT AS CANNOT CONNECT TO COUCHDB
    8:32:40 DATA: Waiting for global DISABLED variable...
    8:32:40 DATA: SYS DATA enabled: false
    8:32:40 ALiVE [m_0|30] Module ALiVE_sys_data INIT COMPLETE TIME: 1.345
    8:32:40 ALiVE SYS DATA - Only one init process per instance allowed! Exiting...

    Doesn't seem like the data is loading st all. Playrts confirmed that when they logged back in, despite saving data, we ended up back at the main (original) spawn point.

    Here's the RPTs, unfortunately they're both in PDF form.because I'm at work and the only way I can get a file through without flagging it is through the PDFs. Thank you for your help so far, this is driving me crazy haha

    https://www.dropbox.com/s/5lkmxl9w194trq7/Alive%20RPT%20asof%2002.13.17.pdf?dl=0

    RPT from this morning
    https://www.dropbox.com/s/f3aiw87sfukfmhs/02.14.18%20Arma%20server%20x64%20RPT.pdf?dl=0

  14. Edited 3 days ago by HeroesandvillainsOS

    Make sure you only have one Data module placed. I haven’t seen that error before but it stands to reason it’s telling you you have more than one which is not allowed (according to the error).

  15. Edited 3 days ago by marceldev89

    @M.Shifty 8:32:40 ALiVE-0 EXITING DATA INIT AS CANNOT CONNECT TO COUCHDB

    This should never appear in your RPT if you have the module set to local, all places where this message would be written to the RPT have a check for the local setting and if it's set it'll skip that message.

  16. I have an update, removed sys_data_auto, the error disappeared but now the original issue is back, server wont save using the save and exit button despite being logged in as admin

    Latest Rpts
    https://www.dropbox.com/s/6hmzxuqgb15oxbe/arma3server_x64_2018-02-14_20-41-54.rpt?dl=0

    https://www.dropbox.com/s/6hmzxuqgb15oxbe/arma3server_x64_2018-02-14_20-41-54.rpt?dl=0

  17. 2 days ago
    Edited 2 days ago by HeroesandvillainsOS

    Hmm not really sure but I still think you may not have setup the Data module correctly. There is an error saying at the end that loading from the DB has failed. I have a feeling if it was set to “local” you wouldn’t see this but I guess I’m not sure.

    Also seeing this quite a bit but I can’t say whether it’s an issue (probably not):

    arning: This version of ALiVE is build for A3 version: 180.143751. The server is running version: 180.143869. Please contact your server administrator and update to the latest ALiVE release version.

    Here, see if this saves and loads. Requires CBA, ALiVE and Spyder Addons only (and Apex because it’s on Tanoa):

    https://www.dropbox.com/home?preview=ALiVE-Tanoa_Showcase.Tanoa.pbo

    If it works just unpack it and see how I set this up, then do the same in your mission. If not post the rpt back here please.

  18. Deleted 2 days ago by HeroesandvillainsOS
  19. Hey man,

    Thanks for the quick reply, I tried downlaoding the file you linked but it just takes me to my dropbox page, Im going to try out the other alive showcases and test that out now.

  20. Edited 2 days ago by HeroesandvillainsOS

    Sorry, proper PBO link is on this page: http://steamcommunity.com/sharedfiles/filedetails/?id=965794580

    Not sure if the showcases have persistence enabled. Some probably do; some probably dont. Just try mine because it definitely does and if it doesn’t work we’ll know for sure it’s not the mission.

  21. Newer ›
 

or Sign Up to reply!