Last player position does not persist (SOLVED)

  1. 5 months ago
    Edited 5 months ago by AngusDLX

    Hello, I'm unfortunately having problems with player persistence when I connect to my server. I use the ALiVE Data module in local mode, enable player persistence in the player options module and use TADST to create a dedicated server without persistent battlefield and auto-init checked.

    Using ALiVE + CBA only (BLU VS OPF), I noticed that only persistence of the player has problems. The rest works normally.

    If I move to another place on the map, go to the menu of ALIVE, enable save player data and then I close the server by Server Save & Exit, when and I come back and open the server again, my position is not saved. I go back to base in editor placed position.

    What I've noticed is if persistence fails and I leave the server and come back, the mission is loaded again and persitence works. Voila I'm in the place I was before.

    I use respawn=3 in Description.ext too and use player multispawn module.

    I removed any other script that might have influence and I also used "waituntil {(player getvariable ["alive_sys_player_playerloaded",false])};"

    But it still fails.

  2. Edited 5 months ago by HeroesandvillainsOS

    Hey I’m wondering if you could try something. TBH I didn’t realize you could toggle player position state persistence in the tablet. If you start the mission with player position state enabled in the module in the editor, this way it’s already on when you start the mission, and then start the mission and “server save and exit,” will your position save then?

    I’m wondering if you toggling it in the tablet in-game is the issue.

    If not could you post the server rpt from when you save and load?

  3. Hi Heroes, I did the test as you said and the result is the same. I did not go back to the position and neither my loadout come back.

    RPT Saving: https://pastebin.com/iMWJAESL

    RPT Loading: https://pastebin.com/KtLwJ1CF

  4. Thanks. @Tupolov @marceldev89

  5. Hmm perhaps there's something wrong with the local saving and player positions, we've had reports about this earlier. I'll try to check this weekend if no one else beats me to it. :)

  6. *Smacks self in face

    Hey, add this to a file called description.ext and place it in your mission root:

    respawnOnStart = -1;

    Should fix your problem.

  7. I used before these days but got the same problem however was with mods installed. I will do the test in a moment and I will report soon

  8. Well it’s my only idea and I use it in my missions lol. Guess it can’t hurt to try until Marcel has a chance to check. :)

  9. Heroes you are the man! Actually the problem was in the absence of respawnOnStart = -1 in the description.ext and our clan members pressing the wrong button thinking it would save the persistence of the player LMAO.

    This respawnOnStart = -1 and player options-> save player data clarification does not appear to be on the wiki in the multispawn part, it would be a good idea to put it there. Suggestion! (If it's already there, sorry I did not see)

    Thank you and Marceldev89 for the support!

 

or Sign Up to reply!