Virtual AI Spawner Issue

  1. 8 weeks ago

    this has been happening for years but it looks like no one has posted it. When AI vehicles groups are in virtual space they move to their waypoint. As soon as they enter real space they still have their waypoint but won't move unless i move the waypoint in zeus a bit they will start to move. this only happens to those on enemy team unless they are spawned before they get a waypoint

  2. Edited 8 weeks ago by marceldev89

    Is this with just A3, CBA and ALiVE? This is the first time I'm hearing about this and I'd assume it would've been reported a ton of times since it's quite obvious.

  3. vehicles move when they move to real space with just those mods above. will try with vcom loaded. funny thing is i never had issues with vcom could be the 2.94. If i can find the 2.91 I will try it

  4. SavageCDN

    Mar 29 Moderator

    There are reports of issues with the current VCOM version. Fixes are in the works from the VCOM side of things last I heard.

  5. here's an update. with only alive and cba. I get same results. Motorized troops will move when spawning into real space but mech and armored troops do not. Its not vcom

  6. my workaround is limit the amount of troops spawned to 100 and set the distance of spawning to infinite so my game can still be reasonably playable. As long as they are in real space and they get an order they will move

  7. Edited 8 weeks ago by HeroesandvillainsOS

    @Shizzak can you post the ALiVE and CBA only mission, and give a detailed step by step for what needs to do in game to see this (tell me exactly what I need to do when I spawn) and state clearly what the actual problem is. I think I follow you just not quite sure.

  8. not sure how i would do that

  9. ? Make a mission. Tell me what the problem is and how to see the problem when I spawn in-game.

    Post the mission on Dropbox and put the link here so I can download it.

  10. Hi!

    It seems that after armored entities enter the spawn range they will stop following any waypoints given to them. I was able to reproduce this by using player combat logistics and ordering any armored or mechanized units in a convoy as they just stop moving when spawning. The same happens when observing armored/mechanized units with Zeus and checking on them en route to their waypoints after being in virtual space. Tested with only Alive and CBA enabled.

  11. I did some further testing and also found out that this only happens in specific parts of the map (tested on Altis).

    https://www.dropbox.com/s/qzt2u0e64waqh4y/mission.7z?dl=0

    I haven't done file sharing before so let me know if I did something wrong..

    To reproduce just order any armored or mechanized units via player combat logistics on your character.

  12. @Djevzi probably no need to have anyone confirm this bug based on what you’re saying. I’d say a dev would need to see this regardless to determine if the behavior is desirable. Go ahead and open a ticket here: https://github.com/ALiVEOS/ALiVE.OS/issues

  13. you beet me to it Djevzi. That is exactly the issue im having. Motorized infantry will move but not mechanized or armored. unless i manually move there waypoint in zeus. I do remember that this wasnt an issue in one of the previous releases. Im testing different releases to find which one worked

  14. Edited 8 weeks ago by HeroesandvillainsOS

    Please open a ticket! Someone! Doesn’t matter who, just be sure to do it with a vanilla repro. Two devs offered to at least look at this at some point so get while the getting is hot.

  15. Also make sure the steps to see this issue are very clear.

  16. Edited 8 weeks ago by marceldev89

    The ticket was made 4 hours ago. :P

  17. thanks @Djevzi

 

or Sign Up to reply!