ALiVE Extension (ALiVEPlugIn) Error: ['{"error":"not_found","reason":"missing"}[SOLVED]

  1. 4 weeks ago

    I'm currently having issues with persistence with alive missions on a dedicated server. It seems that after server save and exit, everything persists except the players. It has worked once when I first added in respawnonstart=-1 and seems to have stopped working after adding the latest update to the server.

    The error ALiVE Extension (ALiVEPlugIn) Error: ['{"error":"not_found","reason":"missing"} seems to always appear as well

    Anyone having this issue or can help?

  2. So it seems that everyone persists except me after server save and exit. Is this supposed to happen or is there a fix?

  3. Edited 4 weeks ago by HeroesandvillainsOS

    Can you post the full rpt and server log from a time you saved and tried to rejoin? Gonna ping @SavageCDN and put him to work :)

    What circumstances is this happening under? “Player Exit” in the esc menu?

  4. SavageCDN

    Jan 23 Moderator

    As @HeroesandvillainsOS mentioned can you provide a 'fresh' RPT and post it to pastebin.com or similar? How are you exiting the server? It's odd that it worked once... you say it stopped after a server update - do you know what was updated?

  5. Hi thanks for the reply!

    The log is 3 hours long so is too big for pastebin, however here is one for a vanilla mission done by Spyder.

    Start
    aliverserver plugin
    https://pastebin.com/71sE5Tp4

    RPT
    https://pastebin.com/DgJtmzAz

    Restart of server
    aliveserver plugin
    https://pastebin.com/KFmYxayS

    RPT
    https://pastebin.com/DdFm1J1w

    Situation is that everyone player exits as they should then I as admin do a server save and exit. When I start the server with the same mission loaded I log in first and my position isnt the same as when I left and I have all of the gear i had at the beginning of the mission last time. However everyone else has gone to their correct positions with the loadouts persisting as well.

    @SavageCDN definitely weird it worked once, I read a post and Heroes said about putting respawnonstart=-1 which I added in and nearly cried with happiness!

    I then updated alive and aliveserver mods from github not the server itself and it stopped working, and i actually did cry a little bit.

    Thanks in advance!

  6. 3 weeks ago

    SavageCDN

    Jan 24 Moderator

    I took a quick look through the first two RPTs and nothing really jumped out at me... you say it only happens to your player everyone else loads back in OK? Do you always join in the same slot in the lobby? Would there be anything unique about your player loadout or setup? Are you using any respawn scripts (code that runs on the player after they respawn)?

    I'll check the other RPTs later today.

  7. Edited 3 weeks ago by HeroesandvillainsOS

    Can you try a newer mission? If you don’t have access to one, and don’t want to make one, I have a ton on Steam with PBO links. Just bare in mind, i’m not sure how you guys are persisting you mission state. Mine are set for “local” saving so you’ll need to change them to “cloud” in the Data module if you guys are using the ALiVE online database (if you’re saving locally you can leave them as is):

    https://steamcommunity.com/profiles/76561198240197958/myworkshopfiles/?appid=107410

  8. Edited 3 weeks ago by digitalrebel

    Yeah it seems everyone else loads in ok. There are no scripts on and I have respawnonstart=-1

    We are saving in the cloud and I'll just do one for our stratis op right now which I built last week.

    The only difference it seems between me and them is that im server save and exiting and they are not

  9. Oh and I have my variable name as z1 and have a zeus gamemaster assigned to me

  10. @HeroesandvillainsOS and @SavageCDN ok so a new mission works, could it be that I haven't updated all of the modules in the operation I wasnt persisting on? The one I've just built works perfectly

  11. SavageCDN

    Jan 24 Moderator

    Yeah I would open your problem mission and delete/replace all ALiVE modules including the data module. Test again and let us know.

  12. Weird that it worked on that one and not on Tanoa, here is the RPT for the mission which wont persist me. Completely remade from scratch, nothing has been brought over at all

    first one
    https://pastebin.com/qYAVjiRq

    Restart
    https://pastebin.com/K07dXfzD

  13. SavageCDN

    Jan 24 Moderator
    Edited 3 weeks ago by SavageCDN

    Same modset between the working map and Tanoa? You could try a vanilla (CBA and ALiVE only) mission to rule out any mod conflicts.

  14. exactly the same, I'll give it a go, did i read somewhere that Vcom is conflicting with it?

  15. SavageCDN

    Jan 24 Moderator

    That is weird. VCOM has conflicted with things in the past (Combat Support stuff mostly) - it would't hurt to disable it for your testing just in case.

  16. I'll give it a go on our op this evening, I've even copied across the data module and others across from the working mission as well as description and init... heres hoping!

  17. SavageCDN

    Jan 24 Moderator

    hehe... praying to the Arma Gods on your behalf

  18. @SavageCDN your prayers worked... weirdly... It apparently is now persisting my position and gear... the Gods of Arma have spoken! Thanks for your help.

    I have another question which is slightly off this topic but I hope you can answer it. Without Connecting the friendly opcom to the enemy Mil placement modules is there a way to have friendly opcom hold an objective after we have captured it?

    For example, our operation next time will be to secure a village, its not been detected by opcom as its not connected however the enemy opcom knows about it and has it held, how do i go about securing the objective and holding it against counter attack once we have moved on?

    Hope that makes sense and let me know if it would be better to start a new thread.

    Cheers

  19. Edited 3 weeks ago by HeroesandvillainsOS

    Try clearing and rerouting the waypoints of some friendly groups via the Operations sub-menu, or delivering some there via Logistics (assuming you’re using it) and see if calling them into the location that way holds it.

  20. nice one thanks will give it a go!

  21. Newer ›
 

or Sign Up to reply!