My OPCOMs don't want to do anything!

  1. 8 months ago

    Hello every1... My name is Aris and I am pretty new in Mission Making and Dedicated Server set-ups. I am working on a persistent mission on LYTHIUM with ALiVE (daaa.. of course...). My set-up pretty quickly is like this: I have many TAORs and 99% of them are Civ Objectives (towns mostly... Settlemens!) and only 2 Mil Objectives 1 for each commander to work as a Base-of-Operations (red for OPFOR (North) and blu for BLUFOR (a really small one a bit South and East)). I have 3 OPCOMS, 2 Red (1 Occupation set and 1 Assymetric) both run the same faction (caf_ag_me_t) and the and 1 blu on occupation with BLU_GEN_F as the faction. Initially I had only 1 Civ Objective Module and I synced all commanders there (now I am trying to put another one but actually is a duplicate). What I tried to achieved here is the two occupation commanders to start from a single point and move on the map to conquer it and somewhere in the middle, the fireworks would start. I also set a CQB module with the OPFOR faction as a forced faction, Military Logistics are in infinite . Civilians are enabled too. My problem now is that: Both commanders keep their forces idle! When I check on my C2ISTAR what are their ordes on all objectives, all of them have white color which means unassigned!. I managed to make the blu commander to move some of his forces by setting the initial spawning force (I had to set spawn units = yes on the Mil Objective module that I use as his initial point and HQ!) really high (I would like to keep friendly forces pretty weak!) but couldn't manage to make the red commander move his forces and also I got NO IDEA about the Assymetric commander!! Also, when the blu commander was moving his forces in my C2ISTAR (with full intel coverage) still the orders from him (and the other commanders) where white!

    And my question... WHAT THE HELL AM I DOING WRONG! I really believe that ALiVE is a POWERFULL, COMPLEX yet SIMPLE to set up. So... Definatelly it is me that do something wrong! Can someone help me a bit here?

    Thanks in advance.
    Aris

    P.s: ArmA as much as you can and always with ALiVE

  2. Are your OPCOMs synched to the enemy TAORs? (perhaps that is not your intent... if so please ignore). If not the commander won't recognize those areas and will not send groups to secure objectives.

    The TAOR you are using as the 'fighting arena' - make sure it's set to objectives only and that there are actual objectives within the TAOR (turn on the debug for the placement module). Make sure OPCOMs are synched to this module.

    If you are new to ALiVE I would highly recommend starting with vanilla units to rule out any issues there (we've had problems in the past with certain mods not working with ALiVE).

  3. Edited 8 months ago by arismagic

    Dear @SavageCDN thank you for your reply. I have only one Civ Objective module and it is synched with all commanders! So, I assume that this means that all OPCOMs are synched with all enemy OPCOMs' TAORs (my setting may be the thing that causes the problem and this is actually part of my initial question!). My "fighting arena" TAORs are objective only and I have debugged it and there are way too many objectives under the areas (at least this is how I understood it! a lot of small dots), I also set the filters to no filter to make sure that IF there is an objective, ALiVE WILL find it!

    I am pretty new to ALiVE and I will follow your instructions.

    Again, thank you for your reply! In case I find any kind of solution or I will pin-point the problem I will let you know immediatelly! Thank you again.

    P.s: I have a CQB module for the same TAORs that fill them with the same faction (forced) with the OPFOR OPCOMs!

  4. What I would do is simplify.. set up your 2 opposing TAORs with commanders and sync them with the one fighting area objective. Make sure groups spawn and are given orders before adding more TAORs, objectives, etc. Let's make sure a simple mission will work with the mods you are using.

    The debug dots are not the objectives.. they are structures or other objects (military or civilian). The objectives will have numbers beside them... see the wiki for more info:

    http://alivemod.com/wiki/index.php/FAQ#What_do_the_numbers_mean_.2850.7C150.29_next_to_the_placement_modules_in_debug.3F

  5. @SavageCDN thank you sir. I will do as you suggest. Thank you for everything and especially for your lightning fast answers!

    P.s: I have seen the numbers from the OPCOMs debugging and I believe that the middle number was "0" (zero) for all of my TAORs!

  6. If your objective priorities are all zeros then that is why the commander is not sending troops. Try replacing that central civ objective with a custom objective and set the priority to max (which IIRC is 999)

    http://alivemod.com/wiki/index.php/Military_Placement_(Custom_Objectives )

  7. Can you have more then one AI commander per side. The case above its the red side ?
    If that is the case, change one of.the red sides to indie

  8. @vansailer no, all commanders have the same problem... I believe that SavageCDN gave the solution to my problem but I have to test it!

  9. Edited 8 months ago by arismagic

    Alright... Dear Sir, @SavageCDN you were right! I did some debugging on an really simple set-up and it seems that my OPCOMs couldn't really find any objectives under my TAORs. So, I set-up a Custom Obj. module and when I synched it to OPCOMs, they immediatelly mobilized there forces! So... Cheers for this!

    But, I encountered another problem. When I set-up more than one Custom Obj. modules (with different priorities too!) I get a message from the OPCOM debugging that says something like No more groups found . I have placed a full 1200 battalion for each of my OPCOMs and I have set the Logistics to infinite So I got many questions here as I couldn't find an answer on the wikis!

    1st: I thought that since there are 1200 "people" under my OPCOM's orders, they would suffice for almost the whole map (Takistan for example!). Am I wrong? Does my OPCOM needs more than that???

    2nd: If I spawn only a small amount of squads (for example 2 platoons (60)) for my OPCOM, is he/it gonna be able to use only these or can request reinforcments?

    3rd (which actually comes as a continuation of the 2nd): Logistics and Reinforcments are only to replenish casualties or OPCOMs can ask reinforcments so they can continue their operations cause, the way I see it is: IF you have many objectives (with many TAORs for example) and not enough forces (especially if OPCOM is set to Occupy OPCOM eventually won't be able to pursue his mission/objectives anymore due to inssufficient human resources! Is that true?

    and 4th (which may be a bit irrelevant): Does the Civilian Placement module always debug the civilian placement with objectives with zero priority? Because I always get many zero priority objective and civilians spawn correctly!

    Again, thank you in advance and I am really sorry for the big posts!

  10. Edited 8 months ago by arismagic

    Alright! @SavageCDN, Sir, here I am again. I managed to mobilize a big amount of forces by setting down a bif BLUFOR force and by minimizing the number of objectives. After some objectives were captured by the commander and after the OPCOM analysis, the OPCOM ordered the TACOM to attack another objective and TACOM received a message that was saying "no groups available"! So my questions:

    In which cases a message like this may pop? And what it may mean?

    Does the OPCOM "garrisons" troops in any and all the objectives that he captures and secures and if yes, is there a way to change this? (e.g. There is an objective on the edge of the map away from the front lines and it seems that OPCEM has garrisone about 6-10 profiles there and at the same time, he is unable to continue offensive operations!)

    What happens if OPCOM indeed "runs out" of available units due to garrison duty?

    Is there a way to mobilize the garrisoned units depending on the objective's priority (e.g. if there is a small priority objective and an objective with higher priority needs defence or recapture)

    Again, my question from my previous do reinforcments are asked for maintaining ability to continue offensive operations or they are called only for casualties replenishments?

    Again, thanks in advance for your time!

  11. Edited 8 months ago by SavageCDN

    Sorry for the late reply.

    The commander will send groups to all objectives to guard/patrol. If you have too many objectives you may run out of available groups in which case the commander will stop giving new orders and all groups will remain in situ. I would check your placement modules on either side and reduce the number of objectives (there is a filter for this) either by size or priority.

    Objective Filters provide options to restrict objective clusters by size or relative priority, so for example it is possible to identify only large military bases and airfields as objectives, excluding smaller bunkers and watchtowers.

    BCRs are not reinforcements but Battle Casualty Replacements... basically it won't add new groups but will replace destroyed groups depending on the module settings

    http://alivemod.com/wiki/index.php/Military_AI_Commander#Usage

    Technically speaking, Military Logistics provide replacements and not reinforcements. The AI Commander will only request replacements for units that have been destroyed since mission start. If the AI Commander starts with zero units, it will never request replacements because as far as it's concerned it will never lose any. If you set up a mission this way, the Player can still call in reinforcements using the Player Combat Logistics module.

    Re: OPCOM and attacks:

    The number of groups used by the AI Commander to conduct a recce/attack, reserve or defend operation is determined by the AI Commander's strategy.

    Invasion:
    4 Attack, 1 Reserve, 2 Defend

    Occupation:
    4 Attack, 1 Reserve, 5 Defend

  12. Dear @SavageCDN , no worries about the "latency" on your reply. You were extremelly helpful with all the info and the advise that you sent to me with your previous replies! My questions were answered on discord server from SpyderBlack723 but your contribution here completed the picture for me. Now I believe that I have a better undestanding of how the OPCOMs and the Logistics work for AI and how to set my missions! I will declare this post as [SOLVED] thanks to you and I will be available to contribute to the forums for your wonderfull mod. Again, thank you for everything.

    ArmA as much as you can and always with ALiVE.

  13. 7 months ago

    Glad to help!

  14. 3 months ago

    I have exactly the same problem with no group available issue even if there are hundreds of group sitting at one starting objective. It seems to have something to do with the distance to the next objective. But could you @ arismagic share the solution you got here?

  15. 2 months ago

    Dear @shi4stone although the post is pretty old, I STRONGLY BELIEVE that the problem was the number of the objectives that I had set on the map. Also, from my small experience with ALiVE, I believe that OPCOMs have a bit of an issue with huge amounts of profiles spawned on a single objective! I would recommend you to lower the number of objectives and maybe spread the huge amount of starting forces to maybe 2-3-4 objectives. If you do not have such objectives near the starting location of your liking on the map you use, you can set Custom Objectives and use them like spawn points (although some of the spawning units WILL stay put to guard it!). Another thing that I have encountered with placing modules is that when the forces are set to really high numbers (not the manual ones but the presets the module has (like "platoon (30-60)", "company (100-400)" etc.) the profiles that spawn do not always correspond to the actuall settings! Please, try my suggestions out and send me a feed back here. Cheers

  16. it is kind of working. i do notice if there is only one objective in the placement area, the units tends to stuck together. but do opcom takes into account terrain to objective? because it seems always attack in direction with better roads first but not in the hilly area even if the enemy is very close by.

    Another strange thing though the virtual profile on map does not seems to be fully updated when debug activated. some profile has either moved or died, but still show on map, and wont spawn unit if player is close by. Save and load then these profiles desappears. What's the difference in faded color profile vs stronger colored ones?

  17. Dear @shi4stone here is my experience on the subjects that you mentioned:

    i do notice if there is only one objective in the placement area, the units tends to stuck together

    Yes, I have encountered the same issue with only one objective on the placement area, so I tend to place a lot of TAORs and manage their filters to achieve what I need!

    but do opcom takes into account terrain to objective? because it seems always attack in direction with better roads first but not in the hilly area even if the enemy is very close by

    I believe that "pathing" or "pathfinding" is doing something like this but I am not really sure. Cannot really answer this question!

    Another strange thing though the virtual profile on map does not seems to be fully updated when debug activated. some profile has either moved or died, but still show on map, and wont spawn unit if player is close by

    Some times, enemy "objects" have not really been set to "dead" state and/or are still on "revive"/"unconsious" state so profiles actually are not "dead"/"destroyed" so, they probably are recognized as "alive" profiles. Sometimes, during my test runs I check this with Zeus.

    What's the difference in faded color profile vs stronger colored ones?

    Faded profiles are not spawned and the bold ones are the spawned profiles (the ones that players can actually fight/see/interact with). Hope I helped, send me what else you may need! Cheers mate!

  18. Super helpful! Thanks buddy!

    Was there a path finding option that needs to be turn on then? Cause I think all the profiles just seem to travel at straight line on map. Spyder does say that alive took into account of terrain in discord. I just hope I could notice clearly the effect in game.

    @arismagic

    Some times, enemy "objects" have not really been set to "dead" state and/or are still on "revive"/"unconsious" state so profiles actually are not "dead"/"destroyed" so, they probably are recognized as "alive" profiles. Sometimes, during my test runs I check this with Zeus.

    ok that's interesting. those profiles wont spawn either with player or zeus nearby. wish there is a way to refresh the map and remove them in game, than having to save and load the game.

    Anyway i am having a blast with alive, not so hard to set up a simple mission but very difficult get things right (right balance, working opcom, achievable objectives). it is a lot of trial and error to understand what is the right balance between number of profiles, objectives, size of the map etc.

  19. @shi4stone mate, about the "forgotten" profiles on the map, just make sure that ALL the enemy models on a group/squad are dead before you make sure that the profiles are not properly cleared also, keep in mind that the vehicles of a spawned profiles are counted towards the "alive"ability of the profile it self until a player use them!

    Also, about the pathing, I believe there is a box in Virtual Entities (or how it is called anyway) module that is called "pathfinding" which actually places many waypoints on the map for the profiles and I believe that it takes acount of the map even for waypoints!

  20. i am fairly sure those undead profiles have no units around, as i zeus around that area there are no units to spawn. also upon save and load those profiles disappear

    pathfinding yes it is in the Virtual AI, says highly experimental... scares me off but i give it try. have you used that?

  21. Newer ›
 

or Sign Up to reply!