ALiVE Menu won't pop up, only hear a "bloop" sound

  1. 3 weeks ago

    Hello! I'm trying to use the Combat Support module in one of my missions, this is the first time I've tried support assets. I have only tried the Artillery submodule, and it looks like my only problem is that the ALiVE menu won't pop up, all I hear is the ARMA "bloop" UI sound like it's saying "no, you can't do that, something else needs to happen before you can do that." I know it's bound, I have tried both Custom Action 20 and the Configure Addons / ALIVE MENU keybinds, same "bloop" sound.

    Let me know where I'm going wrong:

    * Mission is on the Summer Chernaurus map.

    * I inserted the main support module and the artillery submodule, and synced the artillery submodule to the main support module.

    * I have the main support module with "Laserdesignator" set as the required loadout item, which ingame is the Laser Designator "Sand", IIRC. When I start my mission, I grab it from a Virtual Arsenal, I don't have a custom loadout set for any units at the moment.

    * I am playing as the Russians, and the artillery units spawn correctly as the rhs_2s3_tv, the same units as I set in the Artillery Support submodule options. They are friendly to my units and to me, so that's good, means we're recognized as being on the same side.

    * Armed with the Laserdesignator item, I click CTRL-9 (my keyboard does not have the app menu key so I added this keybind in Configure Addons), but I only hear the "bloop" sound. Nothing happens other than that sound.

    MOD INFO:

    I'm using ALiVE with RHS USA and AFRF, CUP Core & Terrain, and ACE3, all mods are subscribed from the Steam Workshop from the original authors, along with the dependencies which I believe is only CBA.

  2. Does it open if you bind it back to the default app menu key? Or does your keyboard not have that?

  3. Edited 3 weeks ago by dsrtfx

    The default binding is still there, I have just added another keybind to it.

    When I delete my *added* keybind (Ctrl-9) and add a different keybind (Ctrl-8, for instance), then the previous *added* keybind ceases to work (Ctrl-9), and the new keybind (Ctrl-8) then works, but again, "works" meaning it's not displaying the ALiVE menu, just triggers the ARMA UI "can't do that" sound.

  4. Edited 3 weeks ago by HeroesandvillainsOS

    The sound you’re hearing is the sound the ALiVE menu makes when it opens. But apparently, the UI itself isn’t opening which yeah, that’s a problem (and unfortunately a few people have reported this).

    To me it seems tied to people binding the key to something other than default (app menu is the default key), possibly with a bug in CBA. Can you try going back to the default key, making sure your CBA is up to date, then completely restarting your PC and seeing if it finally works?

  5. It has to be the cba update of sept 12. The steam workshop has 3 pages of complaints.

    I changed my binding to shift+middle mouse button and get this error.

    23:52:22 [CBA] (keybinding) WARNING: Keybind alive$openmenu's default keybind is invalid [DIK: 4.87653e+008] x\cba\addons\keybinding\fnc_addKeybind.sqf:106

    seems no matter what I bind the openmenu to it comes back with this error.

  6. Edited 3 weeks ago by HeroesandvillainsOS

    Is there any option in game to go back to the default preset bindings for your addons?

  7. Edited 3 weeks ago by HeroesandvillainsOS

    Maybe seeing as you have a definite error message relating to CBA, Commy (CBA dev) can help you over in the CBA thread on BI forums? The guy seems like a real whiz and can probably help you troubleshoot this. Couldn’t hurt asking over there for sure.

  8. Edited 3 weeks ago by jtareb1

    Nah I cannot rebind....I don't think the action key ever worked on my keyboard. I have tested it online and its the only button that does nothing.

    I will message him...from comments it appears key binding has been a big issue with CBA for some time.

    thx

    I posted a message there...will let you know what they say.

  9. Yeah all my CBA keybinds (which I didn't change) now have to either have the Shift or Ctrl key used in order to activate anything in Arma 3 after their last "update". Case in point is my Zeus activation key was/is default set to Y and I didn't adjust it. I now have to hold Ctrl then press Y for Zeus to activate....If I change the keybind to Ctrl-Y it doesn't work.

  10. ok got the cba error(somehow got mapped to custom user 20) fixed but the Alive problem still exists..just a bleep but no access to the c2 menu

    Just set up a simple one on one bash and got this error in both single and multi player
    14:16:44 CallExtension 'ALiVEPlugIn' could not be found
    14:16:44 "THERE IS A PROBLEM WITH THE ALIVE PLUGIN!"
    14:16:44 CallExtension 'ALiVEPlugIn' could not be found
    14:16:44 "THERE IS A PROBLEM WITH THE ALIVE PLUGIN!"
    14:16:44 DATA: Attempting to load ALiVE web services config.
    14:16:44 CallExtension 'ALiVEPlugIn' could not be found
    14:16:44 "THERE IS A PROBLEM WITH THE ALIVE PLUGIN!"
    14:16:44 ALiVE-0 CANNOT CONNECT TO CLOUD SERVICE, DISABLING WEB SERVICES

    This must be from when I tried to access the c2 menu
    14:16:50 ALiVE [m_10|150] Module ALiVE_MIL_C2ISTAR INIT
    14:16:50 No speaker given for

    Mission runs fine. Just no access to the c2 menu. I have tried re-subscribing to Alive on steam but no change.

  11. Just to be clear does the ALiVE menu open at all? The key that gives access to the C2ISTAR menu also opens your basic ALiVE menu (which has Admin and Player options, etc).

  12. No nothing opens

    Went back and deleted the data module and ran the basic scenario as single player which got rid of the plugin error( don't know what's wrong there but it looks like its on my side ).

    waited till everything has loaded, got the laser designator and clicked shift+middle mouse button( binded to the action menu ).

    this was the last response
    15:58:57 No speaker given for

  13. I can talk to the pilot of a CAS transport though with the laserdeg

  14. Are you on Discord? Commy just left a reply in the ALiVE Discord channel (no solution, they’re just trying to figure out if it’s ALiVE’s fault or CBA’s). He may or may not need your rpt. Might not be a bad idea to hop on and follow along there.

  15. Edited 3 weeks ago by HeroesandvillainsOS

    So I got a new keyboard yesterday, one that doesn’t have an app menu key, and I’m having the same issue (rebind key, only get sound and no menu). If anyone has any troubleshooting steps I can follow to reveal the cause of the issue, I’m willing to spend some time with this.

  16. @jtareb1 @Nichols Until this is properly fixed, I was able to get it to work by going in-game and deleting the app menu key bind and replacing it with the left windows key. Then, restarting Arma completely. Somehow this works (thanks @bradon for the tip). It may not work for you guys but worth a shot.

  17. <bangs keyboard off forehead>

    I tried dozens of combos and could not get it to work but it never occurred to me to use the other win key.

    It works.

    Must be some kind of special ability of the win key or something...regardless thanks.

  18. You might want to make this a sticky as I doubt we will be the last users to have this issue.

  19. Friznit

    Oct 29 Administrator

    We're in the process of re-writing the fleximenu code, because this problem keeps randomly cropping up. Hopefully the fix will make the problem go away completely.

  20. last week

    Awesome, good to hear, Friznit! Can't wait to finally use the menu :D

 

or Sign Up to reply!