CBA Eventhandlers not triggered

  1. 4 weeks ago

    Hi there, about 7 months ago I created a topic related to event handlers and I recently just got back to the alivemod again. I've got some event handlers going and when I'm testing it on my local machine it works just fine but not when I move it over to my dedicated server on a different machine. I've tried different ways and as far as I got it to work and find what the problem is, and it something with alive that I've missed or are not understanding, because any AI's spawned from the alive modules aren't triggering the event handler, however, if I spawn an AI from Zeus it works just fine without a problem. Anyone got any ideas on how to resolve this?

    description.ext (I've tried switching CAManBase to Man and All and still no change, I mean it works just fine on my local machine)

    class Extended_Hit_EventHandlers {
    	class CAManBase {
    		hit = "_this call custom_fnc_handleHit;";
    	};
    };

    fn_handleHit.sqf (Just as a test to see if it's being triggered or not)

    params ["_unit","_causedBy","_damage","_instigator"];
    hint format ["Triggered\nUnit: %1\nCausedBy: %2\nInstigator: %3", name _unit, name _causedBy, name _instigator];
  2. I doubt it's causing your problem here, but its convention to use a class to separate your eventhandlers by mod

    class Extended_Hit_EventHandlers {
    	class CAManBase {
                class your_mod_name {
    		    hit = "_this call custom_fnc_handleHit;";
                };
    	};
    };
  3. 3 weeks ago

    @SpyderBlack723 I doubt it's causing your problem here, but its convention to use a class to separate your eventhandlers by mod

    class Extended_Hit_EventHandlers { class CAManBase { class your_mod_name { hit = "_this call custom_fnc_handleHit;"; }; }; };

    Oh I never knew about that, cheers man I'll give it a test and come back with the result shortly!

 

or Sign Up to reply!