"There are are no groups for" (ORBAT created faction)

  1. 2 weeks ago

    Hey there!

    I've created a faction with one group but when I preview the mission ALiVE just keeps informing me that "There are are no groups for OPCOM faction(s) ["alive_zombies_mutants"]! Please check you chose the correct faction(s), and that factions have groups defined in the ArmA 3 default categories infantry, motorized, mechanized, armored, air, sea!"

    I've declared the faction and its group in description.ext like so:

    //////////////////////////////////////////////////////////////////////////////////
    // Config Automatically Generated by ALiVE ORBAT Creator
    // Generated with Arma 3 version 184.144923 on Stable branch
    // Generated with ALiVE version 1.8.0.1808241
    //////////////////////////////////////////////////////////////////////////////////
    
    class CfgGroups {
        class EAST {
    
            class alive_zombies_mutants {
                name = "Alive mutants";
    
                class Infantry {
                    name = "Infantry";
    
                    class o_ua_infantry_mutants_and_zombies_for_alive {
                        name = "Mutants and zombies for ALiVE";
                        side = 1;
                        faction = "alive_zombies_mutants";
                        icon = "\A3\ui_f\data\map\markers\nato\o_inf.paa";
                        rarityGroup = 0.5;
    
                        class Unit0 {
                            position[] = {0,0,0};
                            rank = "SERGEANT";
                            side = 1;
                            vehicle = "O_UA_zombie_2_01";
                        };
                        class Unit1 {
                            position[] = {5,-5,0};
                            rank = "PRIVATE";
                            side = 1;
                            vehicle = "O_UA_zombie_03";
                        };
                        class Unit2 {
                            position[] = {-5,-5,0};
                            rank = "PRIVATE";
                            side = 1;
                            vehicle = "O_UA_zombie_06";
                        };
                        class Unit3 {
                            position[] = {10,-10,0};
                            rank = "PRIVATE";
                            side = 1;
                            vehicle = "O_UA_zombie_05";
                        };
                        class Unit4 {
                            position[] = {-10,-10,0};
                            rank = "PRIVATE";
                            side = 1;
                            vehicle = "O_UA_zombie_02";
                        };
                        class Unit5 {
                            position[] = {15,-15,0};
                            rank = "PRIVATE";
                            side = 1;
                            vehicle = "O_UA_zombie_01";
                        };
                    };
    
                };
    
            };
    
        };
    };

    In the mission editor I've placed Military AI commander module and in its Override factions field I've typed alive_zombies_mutants

    Then I placed Military placement module and in its Force faction I've typed alive_zombies_mutants
    As usual I've synced those two modules together.

    Then I go and preview the mission and get greeted with the "There are no groups.." debug information.

    Afaik I should have everything set up so what gives? Well.. only thing I haven't declared in the description.ext is class CfgFactionClasses but is that even needed?

  2. Edited 2 weeks ago by marceldev89

    The CfgFactionClasses bit might be required, if I remember correctly.

  3. Thanks for the quick reply marcel!

    I did include the following in description.ext

    class CfgFactionClasses {
        class alive_zombies_mutants {
            displayName = "Russia (MSV)";
            side = 1;
            flag = "";
            icon = "";
            priority = -1;
        };
    };

    but ALiVE still keeps giving the "There are no groups.."

  4. Actually, that message might happen because your faction only has infantry groups. You might have to set the objective module to only spawn infantry using the numeric overrides. Not 100% sure but I vaguely remember something like this.

  5. SpyderBlack723

    Sep 2 Moderator

    I'm not sure if new factions can be declared in mission, it might be restricted to groops. Don't remember the implementation.

  6. Haven't played in a whe thx to work, just getting back to it so warning: memory fuzzy :)

    declaring factions at mission level work(ed) with the limitation that it must use existing units. I made my own RHS "Russian" faction I would include within desired missions. It consisted of all hand made groups populated by RHS, CUP etc soldiers, vehicles etc.

 

or Sign Up to reply!