Manual Server save hangs

  1. 2 years ago
    Used to work for me, now it hangs as in the picture and does nothing. Can supply logs etc if you want. Is this supposed to be automatically done according to a setting in one of the modules?

  2. This has happened to me when using an out-dated version of @aliveserver and also when @aliveserver is not the very last mod loaded on the server.

  3. hmmm, will alter it to the last one as its 2nd and see how it goes. I tried to make it -servermod instead and foudn the misisons hangs.

  4. Nope, remains as per the picture after changing load order. All versions are latest and the same. Picture says saving data and does nothing else. Player profiles half work (position and clothing but not medical) and server i don't think anything is persistent, it worked once a few days back and keeps restoring to that point or restart. Can't explain whats going on.

  5. Can you provide your server's RPT file and the alive.log file found under @alive mod folder? Post to and link back here if possible.

  6. highhead

    27 Apr 2016 Administrator

    Yah - logs please. How long have you been waiting for it to save?

  7. Edited 2 years ago by thebgpikester


    • Pastebin free doesnt accept more than 512KB pastes
    • Assume you meant the @aliveserver (plugin) logs, I searched the entire drive for an Alive.log and got no results despite ALiVE running.
    • I left it over 20 minutes whilst I did the logs and it remained as per screenshot.

    Bit worried about this alive.log....

  8. Sorry my bad... I was indeed referring to the plugin log

  9. So, any thoughts?

  10. We'll need to wait for HH or Tup to take a look at this. HH is in the middle of moving so hold tight.

  11. rgr that. FWIW the server always rolls back to a single save made prior to 1.58 and the player pos/gear too, but player pos will update throughout the server session and save, but on the restart takes us back to the one last week. It's a damn shame I can't launch, I'd like to know if anyone has this working at all, there are so many configurations that can potentially interfere.

  12. Edited 2 years ago by Ary1g

    Same issue on our dedicated server, except a fresh mission (no previous saves). Just hangs when pressing save just like OP. It seems like the command to save isn't even executed based on watching the aliveserver rpt. I could provide the logs, but they look the same as OP with the JSON just pinging every minute(?) or so.

    My workaround for now is to roll back to previous version of ALiVE and Aliveserver until a fix arrives. No problems on that version, same exact fresh mission. I didn't get any save on latest version, but rolled back to previous version to test and everything worked.

    Just hope ALiVE 1.03 works decently on the new 1.58 update.

  13. I'm looking at a rollback too but I'm not sure its going to work, sounds like there were some under-the-bonnet changes.

    I think I'm going to start examining iniDB for persistence, this has never worked for our group and 20 folk are waiting on a promise I made based off this mod.

    I'd rather this was fixed though as on paper it had the solution.

  14. There are some fixes in dev version for persistence.. don't quote me but I'm guessing a hotfix will be out soon™

  15. Tupolov

    4 May 2016 Administrator

    Thank BIS for the issue. Fix will be in 1.0.5, hopefully out before this weekend.

  16. I'm absolutely delighted at your efforts to fix this and engage the community openly, My thanks, and by proxy everyone who plays with me, greatly appreciate your awesome work on this key mod.

  17. Friznit

    6 May 2016 Administrator

    Can you confirm your issue has been fixed?

  18. Unfortunately no. Just literally now updated a client and server and I get the same response although at least my profile loads with the splash in the top right now.
    Still investigating.

  19. OK, i changed mission name and this stopped the hanging, so there must have been a corrupt save. I still can't get the server to save and restore. Ive literally never had it working right. Troubleshoioting is hard because I don;t even know what the desired effect is. I also cannot get Alive markers in this verison working.

  20. Tupolov

    6 May 2016 Administrator
    Edited 2 years ago by Tupolov

    Did you test a vanilla ALiVE mission and follow the server instructions?

    Try Quick Start mission, as that defo works.

  21. Newer ›

or Sign Up to reply!