Map Indexing

  1. last year
    Edited last year by uk_apollo

    Have you had much up-take from the community in helping with map-indexing?
    Is there a list of map-index submissions that haven't yet made it into release, so that others considering helping out don't repeat work already done?

    I'm having a look at what's involved, using @gorgona as an example, following the tutorial: http://alivemod.com/wiki/index.php/Map_Indexing

    When asking it to start indexing it immediately fails with an rpt message of:
    >>>>>>>>>>>>>>>>>> Calling DeWRP to get list of objects
    >>>>>>>>>>>>>>>>>> There was a problem, exiting indexing

    I have:

    • @ALiVE folder correctly named in my mods
    • ALiVEClient.dll and alive_object_blacklist.txt in @ALiVE
    • Mikero's DeWrp.exe and DePbo.dll
    • As a modder I already had DeOgg64.dll. Your wiki link for downloading DeOgg.dll is broken and it's not available on Mikero's devHeaven. I did try copying/renaming deOgg64.dll to deOgg.dll as recommended elsewhere.
    • I have an Environmental Variable PATH = C:\Program Files (x86)\Mikero\DePboTools\bin in which are DeWrp.exe, DePbo.dll, DeOgg.dll
    • DeWrp.exe, DePbo.dll, DeOgg.dll are unblocked
    • \My Documents\Arma 3\Scripts\x\alive\addons\... is present
    • Arma launched with -mod=@ALiVE; @CBA_A3; @gorgona -filePatching

    Regards,
    Apollo

  2. Edited last year by SpyderBlack723

    Anything from here

    https://github.com/ALiVEOS/ALiVE.OS/issues/9

    --

    @Tupolov

  3. Edited last year by marceldev89

    @uk_apollo, try running DeWrp manually and see if it outputs anything useful (like an error).

    DeWrp.exe -D theterrain.pbo
  4. Thanks spyderB & marceldev,

    Executing DeWrp.exe from cmd worked fine:
    DeWrp.exe -D "F:\Games_2\ArmA 3\Mods\@gorgona\addons\gorgona.pbo"

    It ran through a long list of stuff and completed with // No error(s).

    What is the exact syntax for the "Map PBO file path:" inside the @Alive Map Indexer module?
    I have mods on a different drive to the game files, but @gorgona is in the same folder as @alive.

    I've tried:
    @gorgona\addons\gorgona.pbo
    F:\Games_2\ArmA 3\Mods\@gorgona\addons\gorgona.pbo

    This one crashes ArmA dead:
    "F:\Games_2\ArmA 3\Mods\@gorgona\addons\gorgona.pbo"

    I also tried moving @gorgona to the A3 game folder in case it was a mod path problem, same negative result.

    Finally, I've tried another map, @vtr_porquerolles, and get the same immediate error.

  5. The mod needs to be in the Arma 3 folder and the path in indexer module should be relative to the root of the Arma 3 folder like so: @gorgona\addons\gorgona.pbo.

  6. Also try putting @alive in the Arma 3 folder, I guess.

  7. Yes, that's fixed it!

    Both @alive and @map need to be in the ArmA 3 game folder.
    That's probably something the dev's might like to add to the indexing instructions.

    Thanks for your help.

    Apollo [3CB]

  8. Edited last year by uk_apollo

    Ha, I spoke too soon.

    deWrp.exe now does it's thing and finds all the items. But when it completes with "Press any key to continue" and I press Up arrow, Arma crashes. Nothing in the rpt to say why.

  9. Edited last year by marceldev89

    Try running https://technet.microsoft.com/en-us/sysinternals/processmonitor.aspx and filter for arma3.exe during the process. Maybe it shows something useful just before it crashes (like unable to open a file or something).

  10. Edited last year by marceldev89

    procmon instructions, if you're unfamiliar with it:

    -image-

  11. Edited last year by uk_apollo

    I wasn't familiar with process monitor, but have installed it and set up the filter for arma3.exe.

    When A3 is running (just sitting in the editor), there are 80,000+ lines of events relating to it! I'm not really sure how to filter that data to look for something appropriate when it crashes.

    Edit: although I've just noticed it's in chronological order...

  12. No, I'm not seeing anything obvious in procmon just before crash.

  13. Edited last year by marceldev89

    If you were capturing when it crashed then you can save the output via File > save. If you can upload it, I'll take a quick look. Keep in mind that it might contain some personal information (e.g. your windows username).

  14. Friznit

    3 Jun 2016 Administrator

    @uk_apollo Yes, that's fixed it!

    Both @alive and @map need to be in the ArmA 3 game folder.
    That's probably something the dev's might like to add to the indexing instructions.

    Thanks for your help.

    Apollo [3CB]

    It already states that. Be sure to follow the instructions very closely! As you can see though, because it's a script plonked onto BIS's delightful in game interface it's not the most forgiving tool ever. I had the devil of a time when testing it for Tup, as my ArmA insisted on looking in a completely random folder for the staticdata.sqf -filepatching is a common step missed and can cause all sorts of issues.

  15. Edited last year by uk_apollo

    This is what the instructions say:
    "ALiVE must be in @ALiVE folder in ArmA3 (Warning: folder name is case sensitive!)"

    I read that as a warning about the case sensitivity of the @ALiVE folder, rather than as explicitly saying to put @ALiVE in a particular ArmA 3 folder. There's no mention about the map folder location that I've seen.

    Perhaps this might help to clarify for other potential contributors:

    "Both the @ALiVE folder (warning: folder name is case sensitive!) and the custom map to be indexed must be placed inside the ArmA3 game folder (which contains Arma3.exe)."

    Was there any thought about the broken link to the .dll or it's unavailability?

  16. Friznit

    3 Jun 2016 Administrator

    It's a bit lower down but I'll rejig it a bit to make it more explicit and clearer. Thanks for the feedback.

    Can't speak for Mikero's tools. I'll check the links but if he's removed his (old) free versions there's nothing we can do about that unfortunately.

  17. Here is the link to the free Mikero's Tools:

    https://dev.withsix.com/projects/mikero-pbodll/files

    DeOgg...Installer.exe gives me DeOgg64.dll - maybe it detects what version of Windows you're running?

  18. Friznit

    4 Jun 2016 Administrator

    Fixed the links in the insturctions so they're pointing to the correct tools folder in the ALiVE.OS repo.

  19. The link is still broken for me. Am I on the wrong page?

    http://alivemod.com/wiki/index.php/Map_Indexing

    "Acquire a copy of Mikero's Tools, specifically DeWrp.exe and DePbo.dll and DeOgg.dll (the version dated 09/08/2014 seems to work OK)."

    Clicking DeOgg.dll takes me to:
    We need a map.
    Server Error: 404 (Not Found)

  20. @uk_apollo https://github.com/ALiVEOS/ALiVE.OS/wiki/How-to-Index-Maps

  21. Newer ›
 

or Sign Up to reply!