Map Indexing

  1. ‹ Older
  2. 2 years ago

    Hi there,

    I really, really want to help with indexing because all the maps from IFA3 and it's new I44 content give me errors and persistence failure whenever I try to setup a mission there.

    So I'd like to try my luck on indexing these - only I don't understand what to do with the DeWRP.exe. Please, give me a more detailed step-by-step set of instructions on how to install the DeWRP.exe - I didn't understand the whole path thingy...

    I'm on Win 7 (64 Bit OS) and would like to know:

    1) Where to put the DeWRP.exe and it's accompanying .dll files

    2) If I need to create an entirely new environment variable just for the DeWRP.exe - and how exactly to do that

    THX in advance for any help,


  3. Edited 2 years ago by marceldev89

    The easiest way is to put the files in c:\windows\system32\ I guess

  4. Also for a 64 bit system?

  5. And just the files or the files within a folder named DEWRP?

  6. Here comes my .rpt, showing clearly that the dewrp.exe is thr problem:

    I have put it into c:\windows\system32\ both as individual files and as content of a folder named DEWRP. Also I had tried to set up the path stuff pointing to another location, that is, a folder named DEWRP is located in C:\Program Files (x86), leading to this path: C:\Program Files (x86)\DEWRP. And I made a new entry at the environment variables and entered this path. But I don't understand this at all, so maybe that had zero effect or detrimental effect...

    PLZ be more detailed in the instructions; I really never did messing around in my OS's entrails for any game before ;-)

  7. Edited 2 years ago by HeroesandvillainsOS

    It probably doesn't matter as long as you have the windows environment path defined, but the last I checked I had DEWRP.exe, DePBO.dll and DeOgg.dll in this path:

    C:\Program Files (x86)\Mikero\DePboTools\bin

    Those are the only Mikero files which I have DL'd

    It's been awhile since I installed these files, but pretty sure this folder path gets created when installing Mikero's files. I just stuck DEWRP.exe inside there myself and it seems to work ok.

  8. I don't have an installer for Mikero's tools since on the ALiVE Map indexing WIKI, it point to a DL that just offers the And in there, I only find the three files DeWrp.exe, DePBO64.dll and DeOgg64.dll

  9. Edited 2 years ago by tourist

    Even if I put these in C:\Windows\SysWOW64\ it doesn't work. I Tried to setup the path, maybe I did that wrong in the first place. I did it like this:

    1) Open the Tab for changing/creating environment vaiables

    2) Clicked "New" in the User Variables Window

    3) Named it DEWRP x64

    4) Named the value C:\Windows\SysWOW64\DeWrp.exe

    5) clicked ok

    6) added the line C:\Windows\SysWOW64\DeWrp.exe to the path entry in the system variables window below

    7) clicked ok twice; now everything should be saved

    8) still get this error about dewrp when trying to index - SO frustrating!!!

  10. Edited 2 years ago by marceldev89

    Alright, the simplest way I can think of in steps:

    1. Extract the zip file to c:\windows\system32\ (no need to create a subfolder or whatever)
    2. Open the start menu and search for "cmd.exe" (without the quotes) and press Enter
    3. Inside the cmd.exe window type "DeWrp.exe" (without the quotes) and press Enter
    4. It should print some information in the console similar to:
    dewrp x64UnicodeVersion 1.71, Dll 5.24 ""
    Syntax DeWrp [-option] filename[.wrp]
    option -I: List locations and model of all island ID's
    option -L: List Land classes
    option -O: List Objects and their ID's
    option -D: List Objects no ID's
    option -P: don't pause
    Press the ANY key

    If 4 went well then go ahead and try to index the map using the instructions on the wiki. If it didn't then something is seriously wrong with your system and it's beyond what I can (or am willing to) do through a forum. :P

    If the index fails again post the log file from the @ALiVE\indexing\ folder.

  11. Ok, time to post the log file since all I get when doing your 4 steps is that DeWrp opens a GUI which looks like this:

    And here the logfile:

    Any clues? :-(

  12. Same exact issue as tourist - get the GUI + DeWrp error in the RPT. Do not get that Command line prompt that you speak of.

  13. Actually, that's good. Without any parameters DeWrp.exe shows that GUI. If you type something like DeWrp.exe --help it will probably output what I said above.

    @tourist sorry for the huge delay.. didn't notice the post. :D

  14. Figured it out! It was BattlEye causing the issue. Disabled and it worked! Also if you have Win 8, make sure you run it for Win 10 in the module.

  15. Nice. Thanks for sharing the solution. What map are you indexing?

  16. Nam. However, it is not working. Posting another thread explaining the problem

  17. Thanks updated wiki to reflect disabling BE

  18. Got a question - is it possible to bypass an object in the object categorizer? Currently got one object causing an DX11 : OUT_OF_MEMORY error every time I reach it

  19. Friznit

    31 May 2017 Administrator

    Add the object name to alive_object_blacklist.txt

  20. Thank you!

  21. Edited 2 years ago by Burdy323


    So another question - trying to index some I44 maps. Problem is, I dont know which PBO to use.

    There appear to be :


    Problem is, the only one that has a WRP is the ww2_terrainsi44_w_worlds_i44_omaha_v2_w , but according to the log it only blacklists 2 objects and the deWRP finishes within 2 seconds. Is this normal?

  22. Newer ›

or Sign Up to reply!