Transport isn't landing

  1. 2 years ago

    Hey guys,

    we are running a mission and all worked great until APEX. We've got the following bug/feature:

    We are using alive to transport troops by chopper. Since APEX the chopper isn't landing in 9 out of 10 cases. We've tried to place a heli pad, used places with a lot of free space and flat ground. The AI is not able to land that god damn heli...

    we've googled for hours and couldn't find anything that fix our problem. May be some of you know a work through...

    We are using ACE and tried it with RHS, CUP and only VANILLA units. Also we figured out it doesn't matter which map we are using (tested with Alits, Stratis, espacally Tanoa).

  2. It's buggy right now but do the following.

    1. Change helo speed to slow
    2. Tell Heli to land with engine off
    3. Repeat this a few times if necessary

    I'm pretty sure this is fixed in the next ALiVE update.

  3. We had the same problem. Deactivated VCOM, now all works great. Don't know if the problem is related tho.

  4. Friznit

    22 Aug 2016 Administrator

    VCOM breaks Combat Support. You should disable it in the module code line.

  5. @Friznit would that be VCOM AI or VCOM AI Driving?

  6. AFAIK the driving one only affects land vehicles so you should be OK with it.

  7. Edited 2 years ago by Onearmy

    I'm still having this issue. It should be noted that I'm not using any AI mods.

    I got a littlebird to land properly, however the AI does NOT seem to want to land much of anything else.

    EDIT- I have reason to suspect this is the old issue with ACE FRIES coming back to haunt, because once the chopper gets low to a certain point, he'll just go way back up and come around and try again, rinse and repeat.

  8. I believe heli piloting AI was improved with today's 1.64 update if you haven't tried that yet.

    Please test with CBA and ALiVE only and see if it works then. If so, add on mods until it stops working and you have your culprit.

  9. This was after 1.64

  10. 9 months ago

    Hi everyone!
    I'm having the exact same behaviour on Alive transport. We are using ASR.
    Any clue on a possible solution?

  11. Does it happen without ASR AI? Realistically unless this problem can be duplicated with only ALiVE and CBA loaded, with no outside scripts or AI, then I don’t forsee any possible fixes coming from anyone on the ALiVE team.

  12. 7 months ago
    Edited 7 months ago by Onearmy

    Hey, so I just remembered this thread when I was having this issue. The issue is caused by the FRIES system within ACE. For whatever reason, it causes this buggy behavior with landing to occur with Combat Support transport choppers. (It's not just ALiVE either, AI choppers in vanilla always act weird with FRIES). For some reason, even when placed and the "Equip FRIES" attribute isn't checked, the helicopters still come equipped with them.

    I was able to fix it by going into my mission.sqm and removing the FRIES class/attribute from any helicopters set as combat support. Easiest way to find it is just CTRL-F "FRIES" when editing the mission.sqm

    Alternatively there's another quick-and-dirty solution where you can use Zeus and "delete" FRIES on each helicopter affected while in-mission. Of course, if you're doing persistence, this will have to be re-done each time the mission is hosted (it won't when editing the mission.sqm)

    Hope this helps someone, tore my hair out for so long before I figured this out.

  13. Deleted 7 months ago by HeroesandvillainsOS

or Sign Up to reply!