Please ensure you remove any special characters from mission name, group tag etc

  1. last year

    Tupolov

    24 Nov 2015 Administrator
    Edited 2 months ago by Tupolov

    We are seeing issues with special characters [] {} , " etc and persistence, please remove ANY special char from mission names, group tags, etc.

  2. 9 months ago

    Hi Tupolov,

    We are having issues with connecting to the war room via our dedicated server (Vilayer LTD). I ran the #debug von as one of your replies stated, as well as double and triple checked everything. I think the issue may be with our group tag which is "enclan, eternal" .

    Then I saw this post about having some issues with it, however is there a way to change the group tag? I have not been able to find it, thank you

  3. Here is the error showing up in the log:

    Configuration found: C:\Users\Administrator\AppData\Local\ALiVE\alive.cfg
    [2016-04-14 20:50:24] [info] No URL in config. Using default.
    [2016-04-14 20:50:24] [info] Configuration 'alive.cfg' read OK.
    [2016-04-14 20:50:24] [debug] Alive Config:
    [2016-04-14 20:50:24] [debug] Type: JSON
    [2016-04-14 20:50:24] [debug] User: goqomiqe8eto5ojyqeko7a2uvo9ujafu
    [2016-04-14 20:50:24] [debug] Pass: xxxxxxxxxxxxxxxx
    [2016-04-14 20:50:24] [debug] Group: enclan
    [2016-04-14 20:50:24] [debug] URL: http://db.alivemod.com:5984
    [2016-04-14 20:50:24] [info] Checking WarRoom access...
    [2016-04-14 20:50:24] [info] URL: http://alivemod.com/api/authorise?&group=enclan
    [2016-04-14 20:50:24] [error] ###### HandleMessage - StartALiVE ######
    [2016-04-14 20:50:24] [error] Error: You are not authorized to access ALiVE War Room with this account. Check IP and Groupname.
    [2016-04-14 20:50:24] [error] RAW: StartALiVE ['true']
    [2016-04-14 20:50:24] [debug] Return value [['StartALiVE','ERROR','You are not authorized to access ALiVE War Room with this account. Check IP and Groupname.']]
    [2016-04-14 20:50:24] [debug] |/-\ Elapsed time: 384.746ms
    [2016-04-14 20:50:24] [debug] >>> ParseMessage [GroupName]
    [2016-04-14 20:50:24] [debug] Function: GroupName
    [2016-04-14 20:50:24] [debug] Params:
    [2016-04-14 20:50:24] [warning] ALiVE not initialized yet!
    [2016-04-14 20:50:24] [info] GroupName: enclan
    [2016-04-14 20:50:24] [debug] Return value [['enclan']]
    [2016-04-14 20:50:24] [debug] |/-\ Elapsed time: 0ms
    [2016-04-14 20:50:24] [debug] >>> ParseMessage [SendJSON ['GET','sys_data/config','']]
    [2016-04-14 20:50:24] [debug] Function: SendJSON
    [2016-04-14 20:50:24] [debug] Params:
    [2016-04-14 20:50:24] [debug] - [GET]
    [2016-04-14 20:50:24] [debug] - [sys_data/config]
    [2016-04-14 20:50:24] [debug] - []
    [2016-04-14 20:50:24] [warning] ALiVE not initialized yet!
    [2016-04-14 20:50:25] [debug] Return value [['{"_id":"config","_rev":"21-4cbc3d30df3521ae3d57fce739504639","On":"true","EventLevel":5,"PerfData":"false","EventData":"true","MissionData":null,"AAR":"false"}
    ']]
    [2016-04-14 20:50:25] [debug] |/-\ Elapsed time: 530.249ms

  4. 8 months ago
    Edited 8 months ago by alef

    Hi Tupolov, could you please post a more specific list of special characters?
    I'm debugging some peristence in mine and I'm not sure about "." in "onLoadName", thanks.

  5. we use = in front and on end of the clan tag, it seems to be working fine so far.

  6. Tup is travelling for work... I'm not sure what the full list would look like but generally you'd want to avoid:

    ; : ' " < > / \ ? ! @ # $ % & () [] {} *

  7. 6 months ago

    do underscores work?

  8. For mission names at least, underscores are perfectly ok. That's what I use. I can't say about the other categories because I tend to just smush the words to together just to be safe.

  9. Underscores should work just fine

  10. 4 months ago

    Hi, I just wanted to suggest using something like URLEncoding/Decoding to fix the problems with persistence.

    In another post I read about a group using spacing but only the first word came through in the logs.
    If you URLEncode "Cool Group Name" it would be sent like: "Cool%20Group%20Name" in one string.

    I've had the same problem with an app/plugin I build long ago. You can PM me if needed.

  11. 6 weeks ago

    Not working for us. No bullets count or killcount... http://alivemod.com/war-room/showorbat/3109

  12. Tupolov

    Dec 6 Administrator

    Data looks like its there, some of the data is cached so takes few hours to update. What isn't working as I can both kills and shots fired?

  13. 3 weeks ago
    Edited 2 weeks ago by Nichols

    @Tupolov or any other moderator....

    Can you guys take a look at our group and purge all the data associated with the group?

    http://alivemod.com/war-room/showorbat/3856

    Also would it be possible to delete the other Spearhead groups except for this griup linked above and the test group? None of the other groups exist anymore.

  14. last week

    Tupolov

    Jan 12 Administrator
    Edited last week by Tupolov

    We can't purge data unfortunately. Stats are kept for 1 year.

    The other spearhead groups have members, can you ask those people to leave?

 

or Sign Up to reply!