@aliveserver load screen

  1. 2 years ago

    Hi, Somebody can try this mission please?
    I can play without issues, but when I include @aliveserver in server addons, mission is loaded, I see loading screen and map for a instant, but after I see again the loading screen for ever. I can use move controls and hear my walks, some times I can fire, but ever I see loading screen.

    @RHSAFRF @RHSUSAF @task_force_radio @Spyder Addons @Project OPFOR @Kunduz, Afghanistan @CBA_A3 @ALiVE @ACE3 @RHS compatibility files

    PBO: https://mega.nz/#!9pQUCQKY!X_YCTaBlL0y3UEJ0K1vS18c7bzmHGUMZv4w5pqz2k5g
    Editor Mission folder https://mega.nz/#!41pmkLAA!ino_4cp-VE280LNNWzT_MVFDnSWHdBuja0Qh0k6loW4


  2. Tupolov

    12 Oct 2016 Administrator

    Need the server RPT bro thanks

  3. Ok, I will try again, the last time wasn't generating rpt file in server side. Its valid rpt client side?
    Anyway, mission work for you @Tupolov ?

    P.S: Sorry, I had not selected follow topic option.

  4. Edited 2 years ago by Spark

    Server Console:

    12:24:44 Dedicated host created.
    12:25:00 Host identity created.
    12:25:00 Game Port: 2302, Steam Query Port: 2303
    12:32:03 Spark uses modified data file
    12:32:03 Player Spark connecting.
    12:32:03 Mission ALiVE_Kunduz_GCVv2.Kunduz read from bank.
    12:32:06 Player Spark connected (id=76561197988392320).
    12:32:16 Roles assigned.
    12:32:16 Reading mission ...
    12:32:31 Mission read.
    12:33:41 Game started.

    My server rpt file: https://www.dropbox.com/s/mwgc35goh3safdw/arma3server_2016-10-16_12-24-09.rpt?dl=0
    (Its big to paste bin "You have exceeded the maximum paste size of 512 kilobytes per paste.")

    My client rpt file: http://pastebin.com/TfDMvbCK
    Process exit
    Exit code: 0x00000001 - UNABLE_TO_INIT_DXGI
    Running time: 00:13:36.2782601

  5. First double-check and make sure both @CBA_A3, @ALiVE and @aliveserver are up-to-date. Outdated CBA can cause that "can't see anything but can walk around and fire my gun" issue.

    Your server RPT file is full of this line:

    ALiVE OPCOM Waiting for Virtual AI System...
    ALiVE OPCOM Waiting for Virtual AI System...
    ALiVE OPCOM Waiting for Virtual AI System...
    ALiVE OPCOM Waiting for Virtual AI System...

    Check that you actually have a virtual AI module in your mission (which I assume you do since you say it works fine when not loading @aliveserver).

    So does your server eventually crash with that UNABLE_TO_INIT_DXGI message? See here for more info on that error:


  6. They are updated, and mission work without @aliveserver.
    3 people test the mission and 3 can't see nothing in mission, only loading screen and hear his footsteps or launch granade if they throw a granade. Then when I close arma3 with ctrl+alt+sup is when I see the error. My graphic card work great, can't be possible that 3 peoper have issues with graphic card.

    Can you check the mission please? May be that with you work.

  7. Edited 2 years ago by SavageCDN

    If your mission works fine without @aliveserver then try deleting all traces of @aliveserver from your dedi and re-download from the ALiVE website. Make sure no clients are running @aliveserver. Also make sure you re-download your alive.cfg file from the War Room.

    Failing that test a simple mission using just ALiVE, aliveserver and CBA (maybe try one of the demo missions) to rule out any issues with other mods.

  8. I checked insurgency demo misión and work, I will check the others tips and say you. Thanks!

  9. OK that is a good sign. It's possible there is a mod issue.. try using vanilla units in your mission (ie: OPF_F or BLU_F) to see if you can get past the "ALiVE OPCOM Waiting for Virtual AI System..." error messages. There might be multiple problems going on here.

  10. I still testing with mods, at the moment this is my new rpt reinstalled @aliveserver and alive.cfg: https://www.dropbox.com/s/hr5t72y92gspi6z/arma3server_2016-10-19_16-06-48.rpt.txt?dl=0

    What is the [m_32|180] and [m_33|180]? they are the opcom with error or opcom working right? May be that give me the exact module with issue.

    ALiVE OPCOM Waiting for Virtual AI System...
    ALiVE [m_32|180] Module ALiVE_mil_OPCOM INIT
    ALiVE OPCOM Waiting for Virtual AI System...
    ALiVE [m_33|180] Module ALiVE_mil_OPCOM INIT
    ALiVE OPCOM Waiting for Virtual AI System...
    ALiVE OPCOM Waiting for Virtual AI System...

    What is waiting OPCOM? a unit from a mod to be spawned?

    And this?
    Server error: Player without identity Miguegs - 111Sq (id 1513976347)

  11. [m_x] just means it is the x (th) module to initialize.

  12. Make sure you have the Virtual AI module placed in the mission. If you do then most likely the units you are using are not supported by ALiVE - see this list:


    You can ignore the player without identity messages.

    @SpyderBlack723 - so he has over 33 ALiVE modules placed? That sounds like too many...

  13. Edited 2 years ago by Spark

    I need help seriously, please test my mission or check in editor if all is configured right.
    I was 10 hours with this today, not work with vanilla units, I deleted all ace3 modules, 3th opfor faction, only ind_F and blu_F.


    If I write a bad ip address in aliveroom work, but if I write the right data, ip etc not work "ALiVE OPCOM Waiting for Virtual AI System..." I can hear my and alive spawning units.

    2016/10/20, 23:59:05 ALiVE [m_29|200] Module ALiVE_SYS_playeroptions INIT COMPLETE TIME:  0.0440063
    2016/10/20, 23:59:05 ALiVE [m_30|202] Module ALiVE_sys_player INIT
    2016/10/20, 23:59:05 Error in expression <ect 0;
    _result = false;
    if ((typeName _value) == "ARRAY" && {(count _value) ==>
    2016/10/20, 23:59:05   Error position: <_value) == "ARRAY" && {(count _value) ==>
    2016/10/20, 23:59:05   Error Undefined variable in expression: _value
    2016/10/20, 23:59:05 File x\alive\addons\x_lib\functions\data\fnc_isHash.sqf, line 40
    2016/10/20, 23:59:05 Error in expression <_missionName];
    private ["_res"];
    if (ALIVE_sys_data_dictionaryLoaded) then {
    2016/10/20, 23:59:05   Error position: <ALIVE_sys_data_dictionaryLoaded) then {
    2016/10/20, 23:59:05   Error Undefined variable in expression: alive_sys_data_dictionaryloaded
    2016/10/20, 23:59:05 File x\alive\addons\sys_player\fnc_player.sqf, line 134


    -rpt with wrong ip in warroom, mission is working:

    When I close server console with right ip in warroom (mission not work, all normal in console log, game started, etc):
    Lost connection:


    Other recurent error playing a edited spyderblack kunduz insurgency template:

    2016/10/21, 18:26:16  ------------------ Inspecting Hash -------------------- 
    2016/10/21, 18:26:16 Error in expression <l ALIVE_fnc_dump;
    } forEach (_target select 1);
    _level = _level - 1;
    2016/10/21, 18:26:16   Error position: <select 1);
    _level = _level - 1;
    2016/10/21, 18:26:16   Error Generic error in expression
    2016/10/21, 18:26:16 File x\alive\addons\x_lib\functions\diagnostics\fnc_inspectHash.sqf, line 60
  14. I edited 36 missions only 3 success.

    -First success mission v.asym2: changing name mission and name pbo. Not work, Deleting alive data and ALiVE Player Options and creating again both mission work.

    -Second success mission v06: Fix from first success not work, after various tries I Sync a unit with ALiVE Virtual AI System and work. (I miss set debug Off and this did that I re-edited the mission and this not worked again).

    -Third sucess mission v07: Trying fix v06, nothing of previous fix work, finally I sync a opfor unit and set database module debug Off and work, here is the .rpt file with mission working:


    I think that this is related with this: http://alivemod.com/forum/1805-bug-stuck-loading-with-alive-data-solved/0

    I don't understand this:

    @highhead I suggest to turn of all HQ modules (HQ and field HQ) on all Military Placement modules AND to try running Occupation/Invasion for a try! I think this should let you save and restore. We are working hard on the next update, so I hope we can ship it this week!

  15. last year
    Edited last year by Spark

    This month I edited a mission of @HeroesandvillainsOS and again I have this issue if mission use data cloud (mission not is showing in warroom). I select a pj in lobby, mission is downloaded, loading screen is showing, I never see map screen, directly again loading screen is showing and I can hear mission introduction letters and nothing more happens. If I shut down server map its displayed with server conection loss error.

  16. You’ll need to post your server rpt.

  17. Edited last year by Spark

    Server rpt (the same problem a year ago)

  18. This isn’t really my area, though it looks to me like something is causing the Virtual AI module to hang and not init. @marceldev89 @Tupolov ?

    Hey Spark can you try a vanilla ALiVE CBA only mission real quick? I have one called Tanoa Showcase on Steam if you don’t have one handy. Let me know if that works and if that hangs could you post the rpt here?

  19. Edited last year by Spark

    Disabling persistence in alive virtual ai system rpt https://pastebin.com/6udvCkma I can hear intro letters and I can throw a granade, but I only see loading screen.
    Setting local store data work, only have issue when ip is configured right in warroom or when Data module is set in cloud.
    Summarizing, exactly what was commented in previous post. Some times editing mission work, some times not, as I explain in a previous post http://alivemod.com/forum/conversation/post/16153

    I don't have issues with mission saving local data, only when warroom its working (entering a incorrect IP work too).

    My mission working and showing in alive warroom recent operations with data set in local: rpt https://pastebin.com/TC5Zg3iY
    Operation Battle of Lythium FFAAmod (111sq GCV)
    26 minutes ago

    Alive tanoa showcase rpt https://pastebin.com/Wv6uZNjq
    Alive tanoa showcase rpt I edited data module in cloud https://pastebin.com/JFFquayA (is showing it in warroom Recent operations, the others made by me do not appear)

  20. Thanks. Should be much cleaner now without the extra mods. Just hang on tight for one of the devs to take a peek.

  21. Newer ›

or Sign Up to reply!